Nextcloud Server's events information leaked with shared calendars on recurrence exceptions
Priority LOW 17CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-284.
Summary
Nextcloud Server is a self hosted personal cloud system. Private shared calendar events' recurrence exceptions can be read by sharees. It is recommended that the Nextcloud Server is upgraded to 27.1.10 or 28.0.6 or 29.0.1 and that the Nextcloud Enterprise Server is upgraded to 27.1.10 or 28.0.6 or 29.0.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00381 32nd percentileScored 2026-11-07
Fix Fixed security-advisories (nextcloud): 27.1.10, 28.0.6, 29.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | security-advisories | 27.0.0 to before 27.1.10; 27.0.0 to before 28.0.6; 27.0.0 to before 29.0.1 | 27.1.10, 28.0.6, 29.0.1 | Patch available | CNA |
- security-advisories Vendornextcloud Affected 27.0.0 to before 27.1.10; 27.0.0 to before 28.0.6; 27.0.0 to before 29.0.1 Fixed in 27.1.10, 28.0.6, 29.0.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* | 27.0.0 to before 27.1.10 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 27.0.0 to before 27.1.10 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* | 28.0.0 – 28.0.6 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 28.0.0 to before 28.0.6 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:29.0.0:-:*:*:-:*:*:* | 29.0.0 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:29.0.0:-:*:*:enterprise:*:*:* | 29.0.0 | Vulnerable | nextcloud |
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* Versions 27.0.0 to before 27.1.10 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 27.0.0 to before 27.1.10 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* Versions 28.0.0 – 28.0.6 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 28.0.0 to before 28.0.6 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:29.0.0:-:*:*:-:*:*:* Versions 29.0.0 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:29.0.0:-:*:*:enterprise:*:*:* Versions 29.0.0 Vulnerable ·nextcloud
Remediation
- Fix · CNA security-advisories (nextcloud) Fixed in 27.1.10, 28.0.6, 29.0.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-37887
References
More Nextcloud Server vulnerabilities
- TI-2023-20855 Users can delete external storage mount points CVSS 3.1HIGH 7.7
- TI-2023-11091 Nextcloud download permissions can be changed by resharer CVSS 3.1HIGH 7.5
- TI-2023-10624 Nextcloud Server vulnerable to SSRF via filter bypass due to lax checking on IPs CVSS 3.1MEDIUM 5.3
- TI-2025-37238 Cross-site scripting in Nextcloud CVSS 3.1MEDIUM 6.4
- TI-2023-11086 nextcloud vulnerable to Uncontrolled Resource Consumption CVSS 3.1MEDIUM 6.5
- TI-2022-18738 Exception logging in Sharepoint app reveals clear-text connection details CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-37887 · CVE Program
- CVE-2024-37887 · NVD
- FIRST EPSS
- CVE-2024-37887 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences