API Key Leak in lobe-chat
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Lobe Chat is an open-source LLMs/AI chat framework. In affected versions if an attacker can successfully authenticate through SSO/Access Code, they can obtain the real backend API Key by modifying the base URL to their own attack URL on the frontend and setting up a server-side request. This issue has been addressed in version 0.162.25. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| lobehub | lobe-chat | before 0.162.25 | 0.162.25 | Patch available | CNA |
| — | @lobehub/chat (npm) | before 0.162.25 | 0.162.25 | Patch available | GHSA-p36r-qxgx-jq2v |
- lobe-chat Vendorlobehub Affected before 0.162.25 Fixed in 0.162.25 Patch available CNA
- @lobehub/chat (npm) Vendor— Affected before 0.162.25 Fixed in 0.162.25 Patch available GHSA-p36r-qxgx-jq2v
Remediation
- Fix · CNA lobe-chat (lobehub) Fixed in 0.162.25
- Fix · GHSA-p36r-qxgx-jq2v @lobehub/chat (npm) Fixed in 0.162.25 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-37895
- 2026-10-03 Alias added: GHSA-p36r-qxgx-jq2v
References
More lobehub Lobe Chat vulnerabilities
- TI-2024-31448 Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964) CVSS 3.1CRITICAL 9.0
- TI-2024-21831 lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability CVSS 3.1CRITICAL 9.0
- TI-2024-21832 ssrf vulnerability in lobe-chat CVSS 3.1HIGH 8.6
- TI-2025-36970 Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages CVSS 4.0MEDIUM 6.8
- TI-2025-36978 lobe-chat has an Open Redirect CVSS 3.1MEDIUM 4.3
- TI-2024-16187 Lobe Chat unauthorized access to plugins CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-37895 · CVE Program
- CVE-2024-37895 · NVD
- FIRST EPSS
- GHSA-p36r-qxgx-jq2v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences