drivers/perf: hisi_pcie: Fix out-of-bound access when valid event group
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-129 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: drivers/perf: hisi_pcie: Fix out-of-bound access when valid event group The perf tool allows users to create event groups through following cmd [1], but the driver does not check whether the array index is out of bounds when writing data to the event_group array. If the number of events in an event_group is greater than HISI_PCIE_MAX_COUNTERS, the memory write overflow of event_group array occurs. Add array index check to fix the possible array out of bounds violation, and return directly when write new events are written to array bounds. There are 9 different events in an event_group. [1] perf stat -e '{pmu/event1/, ... ,pmu/event9/}'
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.17 and later | 6.1.93, 6.6.33, 6.8.12, 6.9.3, 6.10 | Patch available | CNA |
- Linux VendorLinux Affected 5.17 and later Fixed in 6.1.93, 6.6.33, 6.8.12, 6.9.3, 6.10 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.17 to before 6.1.93; 6.2 to before 6.6.33; 6.7 to before 6.8.12; 6.9 to before 6.9.3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.17 to before 6.1.93; 6.2 to before 6.6.33; 6.7 to before 6.8.12; 6.9 to before 6.9.3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.93, 6.6.33, 6.8.12, 6.9.3, 6.10
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38569
- 2026-10-03 Alias added: GHSA-fr6h-wc99-8m37
References
Patch 5
- https://git.kernel.org/stable/c/3d1face00ebb7996842aee4214d7d0fb0c77b1e9
- https://git.kernel.org/stable/c/8e9aab2492178f25372f1820bfd9289fbd74efd0
- https://git.kernel.org/stable/c/567d34626c22b36579ec0abfdf5eda2949044220
- https://git.kernel.org/stable/c/ff48247144d13a3a0817127703724256008efa78
- https://git.kernel.org/stable/c/77fce82678ea5fd51442e62febec2004f79e041b
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-38569 · CVE Program
- CVE-2024-38569 · NVD
- FIRST EPSS
- GHSA-fr6h-wc99-8m37 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-38569 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences