serial: max3100: Lock port->lock when calling uart_handle_cts_change()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-667 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: serial: max3100: Lock port->lock when calling uart_handle_cts_change() uart_handle_cts_change() has to be called with port lock taken, Since we run it in a separate work, the lock may not be taken at the time of running. Make sure that it's taken by explicitly doing that. Without it we got a splat: WARNING: CPU: 0 PID: 10 at drivers/tty/serial/serial_core.c:3491 uart_handle_cts_change+0xa6/0xb0 ... Workqueue: max3100-0 max3100_work [max3100] RIP: 0010:uart_handle_cts_change+0xa6/0xb0 ... max3100_handlerx+0xc5/0x110 [max3100] max3100_work+0x12a/0x340 [max3100]
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.30 and later | 4.19.316, 5.4.278, 5.10.219, 5.15.161, 6.1.93, 6.6.33, 6.9.4, 6.10 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.30 and later Fixed in 4.19.316, 5.4.278, 5.10.219, 5.15.161, 6.1.93, 6.6.33, 6.9.4, 6.10 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.31 to before 4.19.316; 4.20 to before 5.4.278; 5.5 to before 5.10.219; 5.11 to before 5.15.161; 5.16 to before 6.1.93; 6.2 to before 6.6.33; 6.7 to before 6.9.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.30:-:*:*:*:*:*:* | 2.6.30 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.30:rc2:*:*:*:*:*:* | 2.6.30 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.30:rc3:*:*:*:*:*:* | 2.6.30 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.30:rc4:*:*:*:*:*:* | 2.6.30 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.30:rc5:*:*:*:*:*:* | 2.6.30 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.30:rc6:*:*:*:*:*:* | 2.6.30 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.30:rc7:*:*:*:*:*:* | 2.6.30 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:2.6.30:rc8:*:*:*:*:*:* | 2.6.30 rc8 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.31 to before 4.19.316; 4.20 to before 5.4.278; 5.5 to before 5.10.219; 5.11 to before 5.15.161; 5.16 to before 6.1.93; 6.2 to before 6.6.33; 6.7 to before 6.9.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.30:-:*:*:*:*:*:* Versions 2.6.30 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.30:rc2:*:*:*:*:*:* Versions 2.6.30 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.30:rc3:*:*:*:*:*:* Versions 2.6.30 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.30:rc4:*:*:*:*:*:* Versions 2.6.30 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.30:rc5:*:*:*:*:*:* Versions 2.6.30 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.30:rc6:*:*:*:*:*:* Versions 2.6.30 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.30:rc7:*:*:*:*:*:* Versions 2.6.30 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:2.6.30:rc8:*:*:*:*:*:* Versions 2.6.30 rc8 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.316, 5.4.278, 5.10.219, 5.15.161, 6.1.93, 6.6.33, 6.9.4, 6.10
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38634
- 2026-10-03 Alias added: GHSA-qrpm-p5hj-4xg3
References
Patch 8
- https://git.kernel.org/stable/c/44b38924135d2093e2ec1812969464845dd66dc9
- https://git.kernel.org/stable/c/ea9b35372b58ac2931bfc1d5bc25e839d1221e30
- https://git.kernel.org/stable/c/cc121e3722a0a2c8f716ef991e5425b180a5fb94
- https://git.kernel.org/stable/c/78dbda51bb4241b88a52d71620f06231a341f9ba
- https://git.kernel.org/stable/c/8296bb9e5925b6634259c5d4daee88f0cc0884ec
- https://git.kernel.org/stable/c/93df2fba6c7dfa9a2f08546ea9a5ca4728758458
- https://git.kernel.org/stable/c/865b30c8661924ee9145f442bf32cea549faa869
- https://git.kernel.org/stable/c/77ab53371a2066fdf9b895246505f5ef5a4b5d47
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-38634 · CVE Program
- CVE-2024-38634 · NVD
- FIRST EPSS
- GHSA-qrpm-p5hj-4xg3 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-38634 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences