Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2024-08-27 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2024-38856
- 2026-10-03 Alias added: GHSA-gp2r-34c8-48xq
References
More Apache Ofbiz vulnerabilities
- TI-2024-30292 Apache OFBiz: Confused controller-view authorization logic (forced browsing) KEVCVSS 3.1CRITICAL 9.8
- TI-2024-21190 Apache OFBiz: Path traversal leading to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2024-30542 Apache OFBiz: Prevent use of URLs in files when loading them from Java or Groovy, leading to a RCE CVSS 3.1CRITICAL 9.8
- TI-2021-08129 RCE vulnerability in latest Apache OFBiz due to Java serialisation using RMI CVSS 3.1CRITICAL 9.8
- TI-2023-28119 Apache OFBiz: Pre-authentication Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-26737 Pre-auth RCE in Apache Ofbiz 18.12.09 due to XML-RPC still present CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-38856 · CVE Program
- CVE-2024-38856 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-gp2r-34c8-48xq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences