Malicious remote can add users to arbitrary teams and channels
Priority MEDIUM 40CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5 and 9.8.x <= 9.8.1 fail to properly validate that the channel that comes from the sync message is a shared channel, when shared channels are enabled, which allows a malicious remote to add users to arbitrary teams and channels
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00341 27th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 9.10.0, 9.9.1, 9.5.7 +2github.com/mattermost/mattermost/server/v8 (Go): 9.5.7, 9.7.6, 9.8.2 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 9.9.0; 9.5.0 – 9.5.6; 9.7.0 – 9.7.5; 9.8.0 – 9.8.1 | 9.10.0, 9.9.1, 9.5.7, 9.7.6, 9.8.2 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.5.0 to before 9.5.7 | 9.5.7 | Patch available | GHSA-cmc8-222c-vqp9 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.7.0 to before 9.7.6 | 9.7.6 | Patch available | GHSA-cmc8-222c-vqp9 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.8.0 to before 9.8.2 | 9.8.2 | Patch available | GHSA-cmc8-222c-vqp9 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.9.0 to before 9.9.1 | 9.9.1 | Patch available | GHSA-cmc8-222c-vqp9 |
- Mattermost VendorMattermost Affected 9.9.0; 9.5.0 – 9.5.6; 9.7.0 – 9.7.5; 9.8.0 – 9.8.1 Fixed in 9.10.0, 9.9.1, 9.5.7, 9.7.6, 9.8.2 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.5.0 to before 9.5.7 Fixed in 9.5.7 Patch available GHSA-cmc8-222c-vqp9
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.7.0 to before 9.7.6 Fixed in 9.7.6 Patch available GHSA-cmc8-222c-vqp9
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.8.0 to before 9.8.2 Fixed in 9.8.2 Patch available GHSA-cmc8-222c-vqp9
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.9.0 to before 9.9.1 Fixed in 9.9.1 Patch available GHSA-cmc8-222c-vqp9
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* | 9.5.0 to before 9.5.7; 9.7.0 to before 9.7.6; 9.8.0 to before 9.8.2 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost:9.9.0:*:*:*:*:*:*:* | 9.9.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* Versions 9.5.0 to before 9.5.7; 9.7.0 to before 9.7.6; 9.8.0 to before 9.8.2 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost:9.9.0:*:*:*:*:*:*:* Versions 9.9.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 9.10.0, 9.9.1, 9.5.7, 9.7.6, 9.8.2
- Fix · GHSA-cmc8-222c-vqp9 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.5.7 Advisory →
- Fix · GHSA-cmc8-222c-vqp9 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.7.6 Advisory →
- Fix · GHSA-cmc8-222c-vqp9 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.8.2 Advisory →
- Fix · GHSA-cmc8-222c-vqp9 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-39274
- 2026-10-03 Alias added: GHSA-cmc8-222c-vqp9
References
More Mattermost vulnerabilities
- TI-2024-26695 Malicious remote can invite itself to an arbitrary local channel CVSS 3.1CRITICAL 9.6
- TI-2023-02056 Oauth authorization codes do not expire when deauthorizing an oauth2 app CVSS 3.1CRITICAL 9.1
- TI-2019-15069 An issue was discovered in Mattermost Mobile Apps before 1.26.0. CVSS 3.1CRITICAL 9.1
- TI-2024-26746 Permanently local data deletion by malicious remote CVSS 3.1HIGH 8.7
- TI-2023-06508 Injection in Mattermost CVSS 3.1HIGH 8.8
- TI-2024-27253 One-click Client-Side Path Traversal Leading to CSRF in User Management admin page CVSS 3.1HIGH 8.8
Sources
- CVE-2024-39274 · CVE Program
- CVE-2024-39274 · NVD
- FIRST EPSS
- GHSA-cmc8-222c-vqp9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences