An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14.
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 5 fixed, 11 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-22 and the CVSS impact.
Summary
An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. Derived classes of the django.core.files.storage.Storage base class, when they override generate_filename() without replicating the file-path validations from the parent class, potentially allow directory traversal via certain inputs during a save() call. (Built-in Storage sub-classes are unaffected.)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 5.0 to before 5.0.7 | 5.0.7 | Patch available | GHSA-9jmf-237g-qf46 |
| — | Django (PyPI) | 4.2 to before 4.2.14 | 4.2.14 | Patch available | GHSA-9jmf-237g-qf46 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 5.0 to before 5.0.7 Fixed in 5.0.7 Patch available GHSA-9jmf-237g-qf46
- Django (PyPI) Vendor— Affected 4.2 to before 4.2.14 Fixed in 4.2.14 Patch available GHSA-9jmf-237g-qf46
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 4.2 to before 4.2.14; 5.0 to before 5.0.7 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 4.2 to before 4.2.14; 5.0 to before 5.0.7 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-9jmf-237g-qf46 Django (PyPI) Fixed in 5.0.7 Advisory →
- Fix · GHSA-9jmf-237g-qf46 Django (PyPI) Fixed in 4.2.14 Advisory →
Red Hat 3 advisories
- RHSA-2024:9481 Released 2024-11-13 · Red Hat rating ModerateRed Hat OpenStack Platform 18.0.3 (python-django) security update
- Red Hat OpenStack Services on OpenShift 18.0 python-django-3.2.12-8.el9ost, python3-django-3.2.12-8.el9ost
- RHSA-2024:8906 Released 2024-11-05 · Red Hat rating CriticalSatellite 6.16.0 release
- Red Hat Satellite 6.16 for RHEL 8 ansible-collection-redhat-satellite-4.2.0-1.el8sat, ansible-collection-redhat-satellite_operations-3.0.0-1.el8sat, ansible-lint-5.4.0-1.el8pc +47
- Red Hat Satellite 6.16 for RHEL 9 ansible-collection-redhat-satellite-4.2.0-1.el9sat, ansible-collection-redhat-satellite_operations-3.0.0-1.el9sat, ansible-runner-2.2.1-5.el9pc +47
- RHSA-2024:6428 Released 2024-09-05 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.4 for RHEL 8 automation-controller-4.5.10-1.el8ap, automation-controller-cli-4.5.10-1.el8ap, automation-controller-server-4.5.10-1.el8ap +7
- Red Hat Ansible Automation Platform 2.4 for RHEL 9 automation-controller-4.5.10-1.el9ap, automation-controller-cli-4.5.10-1.el9ap, automation-controller-server-4.5.10-1.el9ap +8
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 1.2 | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Certification Program for Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Certification for Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Certification for Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Discovery 1 | Affected | No fix yet |
| Red Hat OpenStack Platform 16.1 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 16.2 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 17.1 | Affected | No fix yet: Fix deferred |
| Red Hat Storage 3 | Affected | No fix planned: Out of support scope |
| Red Hat Update Infrastructure 4 for Cloud Providers | Affected | No fix yet: Fix deferred |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | Fixed | RHSA-2024:6428 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 9 | Fixed | RHSA-2024:6428 |
| Red Hat OpenStack Services on OpenShift 18.0 | Fixed | RHSA-2024:9481 |
| Red Hat Satellite 6.16 for RHEL 8 | Fixed | RHSA-2024:8906 |
| Red Hat Satellite 6.16 for RHEL 9 | Fixed | RHSA-2024:8906 |
Not affected: 4 products
- Red Hat Ansible Automation Platform 2.4 for RHEL 8
- Red Hat Ansible Automation Platform 2.4 for RHEL 9
- Red Hat Satellite 6.16 for RHEL 8
- Red Hat Satellite 6.16 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-39330
- 2026-10-03 Alias added: GHSA-9jmf-237g-qf46
References
Advisory 3
Other 8
- https://groups.google.com/forum/#%21forum/django-announce
- https://github.com/django/django/commit/2b00edc0151a660d1eb86da4059904a0fc4e095e
- https://github.com/django/django/commit/9f4f63e9ebb7bf6cb9547ee4e2526b9b96703270
- https://docs.djangoproject.com/en/dev/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2024-58.yaml
- https://security.netapp.com/advisory/ntap-20240808-0005
- https://www.djangoproject.com/weblog/2024/jul/09/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-39330 · CVE Program
- CVE-2024-39330 · NVD
- FIRST EPSS
- GHSA-9jmf-237g-qf46 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-39330 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences