drm/komeda: check for error-valued pointer
Priority LOW 25CWE-476Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-476.
Summary
In the Linux kernel, the following vulnerability has been resolved: drm/komeda: check for error-valued pointer komeda_pipeline_get_state() may return an error-valued pointer, thus check the pointer for negative or null value before dereferencing.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0028 20th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.4.279, 5.10.221, 5.15.162 +4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.3 and later | 5.4.279, 5.10.221, 5.15.162, 6.1.95, 6.6.35, 6.9.6, 6.10 | Patch available | CNA |
- Linux VendorLinux Affected 5.3 and later Fixed in 5.4.279, 5.10.221, 5.15.162, 6.1.95, 6.6.35, 6.9.6, 6.10 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.3 to before 5.4.279; 5.5 to before 5.10.221; 5.11 to before 5.15.162; 5.16 to before 6.1.95; 6.2 to before 6.6.35; 6.7 to before 6.9.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc1:*:*:*:*:*:* | 6.10 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc2:*:*:*:*:*:* | 6.10 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc3:*:*:*:*:*:* | 6.10 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.3 to before 5.4.279; 5.5 to before 5.10.221; 5.11 to before 5.15.162; 5.16 to before 6.1.95; 6.2 to before 6.6.35; 6.7 to before 6.9.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc1:*:*:*:*:*:* Versions 6.10 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc2:*:*:*:*:*:* Versions 6.10 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc3:*:*:*:*:*:* Versions 6.10 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.279, 5.10.221, 5.15.162, 6.1.95, 6.6.35, 6.9.6, 6.10
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-39505
- 2026-10-03 Alias added: GHSA-p5hp-xhc7-697m
References
Patch 7
- https://git.kernel.org/stable/c/0674ed1e58e2fdcc155e7d944f8aad007a94ac69
- https://git.kernel.org/stable/c/bda7cdaeebf57e46c1a488ae7a15f6f264691f59
- https://git.kernel.org/stable/c/86042e3d16b7e0686db835c9e7af0f9044dd3a56
- https://git.kernel.org/stable/c/3b1cf943b029c147bfacfd53dc28ffa632c0a622
- https://git.kernel.org/stable/c/9460961d82134ceda7377b77a3e3e3531b625dfe
- https://git.kernel.org/stable/c/99392c98b9be0523fe76944b2264b1847512ad23
- https://git.kernel.org/stable/c/b880018edd3a577e50366338194dee9b899947e0
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-39505 · CVE Program
- CVE-2024-39505 · NVD
- FIRST EPSS
- GHSA-p5hp-xhc7-697m · GitHub Advisory Database · CC BY 4.0
- CVE-2024-39505 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences