Read the docs
TI-2024-26575 Aliases CVE-2024-39651GHSA-jfcj-w3xj-hw99

WordPress WooCommerce PDF Vouchers plugin < 4.9.5 - Unauthenticated Arbitrary File Deletion vulnerability

Priority MEDIUM 47CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in WPWeb WooCommerce PDF Vouchers allows File Manipulation.This issue affects WooCommerce PDF Vouchers: from n/a before 4.9.5.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00496 42nd percentileScored 2026-11-07
Fix Fixed WooCommerce PDF Vouchers (WPWeb): 4.9.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
WPWebWooCommerce PDF Vouchersbefore 4.9.54.9.5Patch availableCNA
  • WooCommerce PDF Vouchers VendorWPWeb Affected before 4.9.5 Fixed in 4.9.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpwebelite:woocommerce_pdf_vouchers:*:*:*:*:*:wordpress:*:*before 4.9.5VulnerableWPWeb
  • cpe:2.3:a:wpwebelite:woocommerce_pdf_vouchers:*:*:*:*:*:wordpress:*:* Versions before 4.9.5 Vulnerable ·WPWeb

Remediation

  • Fix · CNA WooCommerce PDF Vouchers (WPWeb) Fixed in 4.9.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-39651
  2. 2026-10-03 Alias added: GHSA-jfcj-w3xj-hw99

References

  • TI-2024-36469 WordPress WooCommerce - PDF Vouchers plugin < 4.9.9 - Broken Authentication vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-26574 WordPress WooCommerce PDF Vouchers plugin < 4.9.5 - Unauthenticated Multiple Vulnerabilities CVSS 3.1CRITICAL 9.8
  • TI-2024-37235 WordPress WooCommerce - PDF Vouchers plugin < 4.9.9 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-26576 WordPress WooCommerce PDF Vouchers plugin < 4.9.5 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1

Sources