Denial of service in REXML
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 2 fixed, 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ruby | rexml | before 3.3.2 | 3.3.2 | Patch available | CNA |
| — | rexml (RubyGems) | before 3.3.2 | 3.3.2 | Patch available | GHSA-4xqq-m2hx-25v8 |
- rexml Vendorruby Affected before 3.3.2 Fixed in 3.3.2 Patch available CNA
- rexml (RubyGems) Vendor— Affected before 3.3.2 Fixed in 3.3.2 Patch available GHSA-4xqq-m2hx-25v8
Remediation
- Fix · CNA rexml (ruby) Fixed in 3.3.2
- Fix · GHSA-4xqq-m2hx-25v8 rexml (RubyGems) Fixed in 3.3.2 Advisory →
Red Hat 4 advisories
- RHSA-2025:4488 Released 2025-05-06 · Red Hat rating Moderateruby:3.1 security update
- Red Hat Enterprise Linux AppStream (v. 9) ruby-3.1.7-146.module+el9.5.0+23003+a4c328ce.aarch64::ruby:3.1, ruby-3.1.7-146.module+el9.5.0+23003+a4c328ce.i686::ruby:3.1, ruby-3.1.7-146.module+el9.5.0+23003+a4c328ce.ppc64le::ruby:3.1 +47
- RHSA-2025:4063 Released 2025-04-23 · Red Hat rating Moderateruby:3.1 security update
- Red Hat Enterprise Linux AppStream (v. 8) ruby-3.1.7-145.module+el8.10.0+23011+f9d508f8.aarch64::ruby:3.1, ruby-3.1.7-145.module+el8.10.0+23011+f9d508f8.i686::ruby:3.1, ruby-3.1.7-145.module+el8.10.0+23011+f9d508f8.ppc64le::ruby:3.1 +47
- RHSA-2024:6784 Released 2024-09-18 · Red Hat rating Moderateruby:3.3 security update
- Red Hat Enterprise Linux AppStream (v. 8) ruby-3.3.5-3.module+el8.10.0+22271+6a48b0b9.aarch64::ruby:3.3, ruby-3.3.5-3.module+el8.10.0+22271+6a48b0b9.i686::ruby:3.3, ruby-3.3.5-3.module+el8.10.0+22271+6a48b0b9.ppc64le::ruby:3.3 +47
Show 1 more Red Hat advisories
- RHSA-2024:6785 Released 2024-09-18 · Red Hat rating Moderateruby:3.3 security update
- Red Hat Enterprise Linux AppStream (v. 9) ruby-3.3.5-3.module+el9.4.0+22273+463af10f.aarch64::ruby:3.3, ruby-3.3.5-3.module+el9.4.0+22273+463af10f.i686::ruby:3.3, ruby-3.3.5-3.module+el9.4.0+22273+463af10f.ppc64le::ruby:3.3 +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 16.1 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 16.2 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2024:6784, RHSA-2025:4063 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:6785, RHSA-2025:4488 |
Not affected: 4 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 8
- Red Hat OpenStack Platform 17.1
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-39908
- 2026-10-03 Alias added: GHSA-4xqq-m2hx-25v8
References
Advisory 4
More ruby Rexml vulnerabilities
- TI-2024-27968 REXML DoS vulnerability CVSS 3.1HIGH 7.5
- TI-2024-27475 REXML DoS vulnerability CVSS 3.1HIGH 7.5
- TI-2021-09890 The REXML gem before 3.2.5 in Ruby before 2.6.7, 2.7.x before 2.7.3, and 3.x before 3.0.1… CVSS 3.1HIGH 7.5
- TI-2024-33228 REXML ReDoS vulnerability CVSS 4.0MEDIUM 6.6
- TI-2024-23250 REXML contains a denial of service vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-29047 REXML denial of service vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-39908 · CVE Program
- CVE-2024-39908 · NVD
- FIRST EPSS
- GHSA-4xqq-m2hx-25v8 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-39908 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences