Customer data leak via adjustments API endpoint in Sylius
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-639.
Summary
Sylius is an Open Source eCommerce Framework on Symfony. A security vulnerability was discovered in the `/api/v2/shop/adjustments/{id}` endpoint, which retrieves order adjustments based on incremental integer IDs. The vulnerability allows an attacker to enumerate valid adjustment IDs and retrieve order tokens. Using these tokens, an attacker can access guest customer order details - sensitive guest customer information. The issue is fixed in versions: 1.12.19, 1.13.4 and above. The `/api/v2/shop/adjustments/{id}` will always return `404` status. Users are advised to upgrade. Users unable to upgrade may alter their config to mitigate this issue. Please see the linked GHSA for details.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sylius | Sylius | before 1.12.19; 1.13.0 to before 1.13.4 | 1.12.19, 1.13.4 | Patch available | CNA |
| — | sylius/sylius (Packagist) | 1.12.0-alpha.1 to before 1.12.19 | 1.12.19 | Patch available | GHSA-55rf-8q29-4g43 |
| — | sylius/sylius (Packagist) | 1.13.0-alpha.1 to before 1.13.4 | 1.13.4 | Patch available | GHSA-55rf-8q29-4g43 |
| — | sylius/sylius (Packagist) | before 1.9.12 | 1.9.12 | Patch available | GHSA-55rf-8q29-4g43 |
| — | sylius/sylius (Packagist) | 1.10.0-alpha.1 to before 1.10.16 | 1.10.16 | Patch available | GHSA-55rf-8q29-4g43 |
| — | sylius/sylius (Packagist) | 1.11.0-alpha.1 to before 1.11.17 | 1.11.17 | Patch available | GHSA-55rf-8q29-4g43 |
- Sylius VendorSylius Affected before 1.12.19; 1.13.0 to before 1.13.4 Fixed in 1.12.19, 1.13.4 Patch available CNA
- sylius/sylius (Packagist) Vendor— Affected 1.12.0-alpha.1 to before 1.12.19 Fixed in 1.12.19 Patch available GHSA-55rf-8q29-4g43
- sylius/sylius (Packagist) Vendor— Affected 1.13.0-alpha.1 to before 1.13.4 Fixed in 1.13.4 Patch available GHSA-55rf-8q29-4g43
- sylius/sylius (Packagist) Vendor— Affected before 1.9.12 Fixed in 1.9.12 Patch available GHSA-55rf-8q29-4g43
- sylius/sylius (Packagist) Vendor— Affected 1.10.0-alpha.1 to before 1.10.16 Fixed in 1.10.16 Patch available GHSA-55rf-8q29-4g43
- sylius/sylius (Packagist) Vendor— Affected 1.11.0-alpha.1 to before 1.11.17 Fixed in 1.11.17 Patch available GHSA-55rf-8q29-4g43
Remediation
- Fix · CNA Sylius (Sylius) Fixed in 1.12.19, 1.13.4
- Fix · GHSA-55rf-8q29-4g43 sylius/sylius (Packagist) Fixed in 1.12.19 Advisory →
- Fix · GHSA-55rf-8q29-4g43 sylius/sylius (Packagist) Fixed in 1.13.4 Advisory →
- Fix · GHSA-55rf-8q29-4g43 sylius/sylius (Packagist) Fixed in 1.9.12 Advisory →
- Fix · GHSA-55rf-8q29-4g43 sylius/sylius (Packagist) Fixed in 1.10.16 Advisory →
- Fix · GHSA-55rf-8q29-4g43 sylius/sylius (Packagist) Fixed in 1.11.17 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-40633
- 2026-10-03 Alias added: GHSA-55rf-8q29-4g43
References
More Sylius vulnerabilities
- TI-2026-65010 Sylius 2.x before 2.1.16 and 2.2.9 Payment Amount Overwrite CVSS 4.0HIGH 8.7
- TI-2026-24374 Sylius is Missing Authorization in API v2 Add Item Endpoint CVSS 4.0MEDIUM 6.9
- TI-2022-08557 Insufficient Session Expiration in Sylius CVSS 3.1HIGH 8.2
- TI-2026-48275 Sylius Mollie Plugin: Unauthenticated IDOR leaks order token and customer PII CVSS 3.1MEDIUM 6.5
- TI-2026-24378 Sylius has a DQL Injection via API Order Filters CVSS 3.1MEDIUM 5.3
- TI-2024-19437 Sylius 1.12.13 is vulnerable to Cross Site Scripting (XSS) via the "Province" field in Address Book. CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-40633 · CVE Program
- CVE-2024-40633 · NVD
- FIRST EPSS
- GHSA-55rf-8q29-4g43 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences