Implicit override for built-in materializations from installed packages in dbt-core
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution, SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94 and CWE-89.
Summary
dbt enables data analysts and engineers to transform their data using the same practices that software engineers use to build applications. When a user installs a package in dbt, it has the ability to override macros, materializations, and other core components of dbt. This is by design, as it allows packages to extend and customize dbt's functionality. However, this also means that a malicious package could potentially override these components with harmful code. This issue has been fixed in versions 1.8.0, 1.6.14 and 1.7.14. Users are advised to upgrade. There are no kn own workarounds for this vulnerability. Users updating to either 1.6.14 or 1.7.14 will need to set `flags.require_explicit_package_overrides_for_builtin_materializations: False` in their configuration in `dbt_project.yml`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| dbt-labs | dbt-core | before 1.6.14; 1.7.0 to before 1.7.14 | 1.6.14, 1.7.14 | Patch available | CNA |
| — | dbt-core (PyPI) | 1.6.0 to before 1.6.14 | 1.6.14 | Patch available | GHSA-p3f3-5ccg-83xq |
| — | dbt-core (PyPI) | 1.7.0 to before 1.7.14 | 1.7.14 | Patch available | GHSA-p3f3-5ccg-83xq |
- dbt-core Vendordbt-labs Affected before 1.6.14; 1.7.0 to before 1.7.14 Fixed in 1.6.14, 1.7.14 Patch available CNA
- dbt-core (PyPI) Vendor— Affected 1.6.0 to before 1.6.14 Fixed in 1.6.14 Patch available GHSA-p3f3-5ccg-83xq
- dbt-core (PyPI) Vendor— Affected 1.7.0 to before 1.7.14 Fixed in 1.7.14 Patch available GHSA-p3f3-5ccg-83xq
Remediation
- Fix · CNA dbt-core (dbt-labs) Fixed in 1.6.14, 1.7.14
- Fix · GHSA-p3f3-5ccg-83xq dbt-core (PyPI) Fixed in 1.6.14 Advisory →
- Fix · GHSA-p3f3-5ccg-83xq dbt-core (PyPI) Fixed in 1.7.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-40637
- 2026-10-03 Alias added: GHSA-p3f3-5ccg-83xq
- 2026-10-30 CVSS score changed · NVD
- 2026-10-30 Weakness changed · NVD
References
Exploit 3
Patch 2
Advisory 3
Sources
- CVE-2024-40637 · CVE Program
- CVE-2024-40637 · NVD
- FIRST EPSS
- GHSA-p3f3-5ccg-83xq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences