ila: block BH in ila_output()
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: ila: block BH in ila_output() As explained in commit 1378817486d6 ("tipc: block BH before using dst_cache"), net/core/dst_cache.c helpers need to be called with BH disabled. ila_output() is called from lwtunnel_output() possibly from process context, and under rcu_read_lock(). We might be interrupted by a softirq, re-enter ila_output() and corrupt dst_cache data structures. Fix the race by using local_bh_disable().
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.10 and later | 4.19.319, 5.4.281, 5.10.223, 5.15.164, 6.1.101, 6.6.42, 6.9.11, 6.10 | Patch available | CNA |
- Linux VendorLinux Affected 4.10 and later Fixed in 4.19.319, 5.4.281, 5.10.223, 5.15.164, 6.1.101, 6.6.42, 6.9.11, 6.10 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.10 to before 4.19.319; 4.20 to before 5.4.281; 5.5 to before 5.10.223; 5.11 to before 5.15.164; 5.16 to before 6.1.101; 6.2 to before 6.6.42; 6.7 to before 6.9.11 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc1:*:*:*:*:*:* | 6.10 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc2:*:*:*:*:*:* | 6.10 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.10 to before 4.19.319; 4.20 to before 5.4.281; 5.5 to before 5.10.223; 5.11 to before 5.15.164; 5.16 to before 6.1.101; 6.2 to before 6.6.42; 6.7 to before 6.9.11 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc1:*:*:*:*:*:* Versions 6.10 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc2:*:*:*:*:*:* Versions 6.10 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.319, 5.4.281, 5.10.223, 5.15.164, 6.1.101, 6.6.42, 6.9.11, 6.10
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-41081
- 2026-10-03 Alias added: GHSA-q7ch-p7wx-7pf8
References
Patch 8
- https://git.kernel.org/stable/c/7435bd2f84a25aba607030237261b3795ba782da
- https://git.kernel.org/stable/c/96103371091c6476eb07f4c66624bdd1b42f758a
- https://git.kernel.org/stable/c/a0cafb7b0b94d18e4813ee4b712a056f280e7b5a
- https://git.kernel.org/stable/c/feac2391e26b086f73be30e9b1ab215eada8d830
- https://git.kernel.org/stable/c/b4eb25a3d70df925a9fa4e82d17a958a0a228f5f
- https://git.kernel.org/stable/c/522c3336c2025818fa05e9daf0ac35711e55e316
- https://git.kernel.org/stable/c/9f9c79d8e527d867e0875868b14fb76e6011e70c
- https://git.kernel.org/stable/c/cf28ff8e4c02e1ffa850755288ac954b6ff0db8c
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-41081 · CVE Program
- CVE-2024-41081 · NVD
- FIRST EPSS
- GHSA-q7ch-p7wx-7pf8 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-41081 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences