OpenObserve Cross-site Scripting (XSS) vulnerability in `openobserve/web/src/views/MemberSubscription.vue`
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
OpenObserve is an open-source observability platform. Starting in version 0.4.4 and prior to version 0.10.0, OpenObserve contains a cross-site scripting vulnerability in line 32 of `openobserve/web/src/views/MemberSubscription.vue`. Version 0.10.0 sanitizes incoming html.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00359 29th percentileScored 2026-11-07
Fix Fixed openobserve (openobserve): 0.10.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openobserve | openobserve | 0.4.4 to before 0.10.0 | 0.10.0 | Patch available | CNA |
- openobserve Vendoropenobserve Affected 0.4.4 to before 0.10.0 Fixed in 0.10.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openobserve:openobserve:*:*:*:*:*:*:*:* | 0.4.4 to before 0.10.0 | Vulnerable | openobserve |
- cpe:2.3:a:openobserve:openobserve:*:*:*:*:*:*:*:* Versions 0.4.4 to before 0.10.0 Vulnerable ·openobserve
Remediation
- Fix · CNA openobserve (openobserve) Fixed in 0.10.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-41809
References
Patch 2
More Openobserve vulnerabilities
- TI-2024-16347 OpenObserve Privilege Escalation Vulnerability in Users API CVSS 3.1CRITICAL 10.0
- TI-2024-27852 OpenObserve stored XSS vulnerability may lead to complete account takeover CVSS 3.1HIGH 8.8
- TI-2026-28348 OpenObserve has a SSRF Protection Bypass via IPv6 Bracket Notation in validate_enrichment_url CVSS 3.1HIGH 7.7
- TI-2024-16561 OpenObserve Unauthorized Access Vulnerability in Users API CVSS 3.1CRITICAL 9.1
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences