Read the docs
TI-2024-27959 Aliases CVE-2024-41937GHSA-w7cp-g8v7-r54m

Apache Airflow: Stored XSS Vulnerability on provider link

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0173 77th percentileScored 2026-11-07
Fix Fixed Apache Airflow (Apache Software Foundation): 2.10.0apache-airflow (PyPI): 2.10.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Airflowbefore 2.10.02.10.0Patch availableCNA
—apache-airflow (PyPI)before 2.10.02.10.0Patch availableGHSA-w7cp-g8v7-r54m
  • Apache Airflow VendorApache Affected before 2.10.0 Fixed in 2.10.0 Patch available CNA
  • apache-airflow (PyPI) Vendor— Affected before 2.10.0 Fixed in 2.10.0 Patch available GHSA-w7cp-g8v7-r54m

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*before 2.10.0VulnerableApache
  • cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:* Versions before 2.10.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Airflow (Apache Software Foundation) Fixed in 2.10.0
  • Fix · GHSA-w7cp-g8v7-r54m apache-airflow (PyPI) Fixed in 2.10.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-41937
  2. 2026-10-03 Alias added: GHSA-w7cp-g8v7-r54m

References

  • TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
  • TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
  • TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
  • TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
  • TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
See all 157 →

Sources