An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15.
Priority MEDIUM 41CWE-130Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15. The urlize() and urlizetrunc() template filters are subject to a potential denial-of-service attack via very large inputs with a specific sequence of characters.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01258 69th percentileScored 2026-11-07
Fix Partial Django (PyPI): 5.0.8, 4.2.15Red Hat: 2 advisoriesRed Hat: 3 fixed, 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 5.0 to before 5.0.8 | 5.0.8 | Patch available | GHSA-795c-9xpc-xw6g |
| — | Django (PyPI) | 4.2 to before 4.2.15 | 4.2.15 | Patch available | GHSA-795c-9xpc-xw6g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 5.0 to before 5.0.8 Fixed in 5.0.8 Patch available GHSA-795c-9xpc-xw6g
- Django (PyPI) Vendor— Affected 4.2 to before 4.2.15 Fixed in 4.2.15 Patch available GHSA-795c-9xpc-xw6g
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 4.2 to before 4.2.15; 5.0 to before 5.0.8 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 4.2 to before 4.2.15; 5.0 to before 5.0.8 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-795c-9xpc-xw6g Django (PyPI) Fixed in 5.0.8 Advisory →
- Fix · GHSA-795c-9xpc-xw6g Django (PyPI) Fixed in 4.2.15 Advisory →
Red Hat 2 advisories
- RHSA-2025:1335 Released 2025-02-12 · Red Hat rating ImportantRHUI 4.11 security, bugfix, and enhancement update
- RHUI 4 for RHEL 8 python-aiohttp-3.9.4-1.el8ui, python-cryptography-42.0.8-1.el8ui, python-django-4.2.15-1.el8ui +13
- RHSA-2024:6428 Released 2024-09-05 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.4 for RHEL 8 automation-controller-4.5.10-1.el8ap, automation-controller-cli-4.5.10-1.el8ap, automation-controller-server-4.5.10-1.el8ap +7
- Red Hat Ansible Automation Platform 2.4 for RHEL 9 automation-controller-4.5.10-1.el9ap, automation-controller-cli-4.5.10-1.el9ap, automation-controller-server-4.5.10-1.el9ap +8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Discovery 1 | Affected | No fix yet |
| Red Hat Satellite 6 | Affected | No fix yet |
| RHUI 4 for RHEL 8 | Fixed | RHSA-2025:1335 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | Fixed | RHSA-2024:6428 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 9 | Fixed | RHSA-2024:6428 |
Not affected: 6 products
- RHUI 4 for RHEL 8
- Red Hat Ansible Automation Platform 2
- Red Hat Ansible Automation Platform 2.4 for RHEL 8
- Red Hat Ansible Automation Platform 2.4 for RHEL 9
- Red Hat Certification Program for Red Hat Enterprise Linux 9
- Red Hat Certification for Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-41990
- 2026-10-03 Alias added: GHSA-795c-9xpc-xw6g
References
Advisory 2
Other 8
- https://groups.google.com/forum/#%21forum/django-announce
- https://github.com/django/django/commit/7b7b909579c8311c140c89b8a9431bf537febf93
- https://github.com/django/django/commit/d0a82e26a74940bf0c78204933c3bdd6a283eb88
- https://docs.djangoproject.com/en/dev/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2024-68.yaml
- https://security.netapp.com/advisory/ntap-20240905-0007
- https://www.djangoproject.com/weblog/2024/aug/06/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-41990 · CVE Program
- CVE-2024-41990 · NVD
- FIRST EPSS
- GHSA-795c-9xpc-xw6g · GitHub Advisory Database · CC BY 4.0
- CVE-2024-41990 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences