An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15.
Priority MEDIUM 52CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 6 fixed, 3 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-89.
Summary
An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15. QuerySet.values() and values_list() methods on models with a JSONField are subject to SQL injection in column aliases via a crafted JSON object key as a passed *arg.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01503 74th percentileScored 2026-11-07
Fix Partial Django (PyPI): 5.0.8, 4.2.15Red Hat: 4 advisoriesRed Hat: 6 fixed, 3 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 5.0 to before 5.0.8 | 5.0.8 | Patch available | GHSA-pv4p-cwwg-4rph |
| — | Django (PyPI) | 4.2 to before 4.2.15 | 4.2.15 | Patch available | GHSA-pv4p-cwwg-4rph |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 5.0 to before 5.0.8 Fixed in 5.0.8 Patch available GHSA-pv4p-cwwg-4rph
- Django (PyPI) Vendor— Affected 4.2 to before 4.2.15 Fixed in 4.2.15 Patch available GHSA-pv4p-cwwg-4rph
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 4.2 to before 4.2.15; 5.0 to before 5.0.8 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 4.2 to before 4.2.15; 5.0 to before 5.0.8 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-pv4p-cwwg-4rph Django (PyPI) Fixed in 5.0.8 Advisory →
- Fix · GHSA-pv4p-cwwg-4rph Django (PyPI) Fixed in 4.2.15 Advisory →
Red Hat 4 advisories
- RHSA-2025:1335 Released 2025-02-12 · Red Hat rating ImportantRHUI 4.11 security, bugfix, and enhancement update
- RHUI 4 for RHEL 8 python-aiohttp-3.9.4-1.el8ui, python-cryptography-42.0.8-1.el8ui, python-django-4.2.15-1.el8ui +13
- RHSA-2025:1249 Released 2025-02-10 · Red Hat rating Importantupdated discovery container images
- Discovery 1 for RHEL 9 discovery/discovery-server-rhel9, discovery/discovery-ui-rhel9
- RHSA-2024:8906 Released 2024-11-05 · Red Hat rating CriticalSatellite 6.16.0 release
- Red Hat Satellite 6.16 for RHEL 8 ansible-collection-redhat-satellite-4.2.0-1.el8sat, ansible-collection-redhat-satellite_operations-3.0.0-1.el8sat, ansible-lint-5.4.0-1.el8pc +47
- Red Hat Satellite 6.16 for RHEL 9 ansible-collection-redhat-satellite-4.2.0-1.el9sat, ansible-collection-redhat-satellite_operations-3.0.0-1.el9sat, ansible-runner-2.2.1-5.el9pc +47
Show 1 more Red Hat advisories
- RHSA-2024:6428 Released 2024-09-05 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.4 for RHEL 8 automation-controller-4.5.10-1.el8ap, automation-controller-cli-4.5.10-1.el8ap, automation-controller-server-4.5.10-1.el8ap +7
- Red Hat Ansible Automation Platform 2.4 for RHEL 9 automation-controller-4.5.10-1.el9ap, automation-controller-cli-4.5.10-1.el9ap, automation-controller-server-4.5.10-1.el9ap +8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet |
| Red Hat Certification Program for Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Certification for Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Discovery 1 for RHEL 9 | Fixed | RHSA-2025:1249 |
| RHUI 4 for RHEL 8 | Fixed | RHSA-2025:1335 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | Fixed | RHSA-2024:6428 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 9 | Fixed | RHSA-2024:6428 |
| Red Hat Satellite 6.16 for RHEL 8 | Fixed | RHSA-2024:8906 |
| Red Hat Satellite 6.16 for RHEL 9 | Fixed | RHSA-2024:8906 |
Not affected: 6 products
- RHUI 4 for RHEL 8
- Red Hat Ansible Automation Platform 2
- Red Hat Ansible Automation Platform 2.4 for RHEL 8
- Red Hat Ansible Automation Platform 2.4 for RHEL 9
- Red Hat Satellite 6.16 for RHEL 8
- Red Hat Satellite 6.16 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-42005
- 2026-10-03 Alias added: GHSA-pv4p-cwwg-4rph
References
Advisory 2
Other 8
- https://groups.google.com/forum/#%21forum/django-announce
- https://github.com/django/django/commit/32ebcbf2e1fe3e5ba79a6554a167efce81f7422d
- https://github.com/django/django/commit/f4af67b9b41e0f4c117a8741da3abbd1c869ab28
- https://docs.djangoproject.com/en/dev/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2024-70.yaml
- https://security.netapp.com/advisory/ntap-20240905-0007
- https://www.djangoproject.com/weblog/2024/aug/06/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-42005 · CVE Program
- CVE-2024-42005 · NVD
- FIRST EPSS
- GHSA-pv4p-cwwg-4rph · GitHub Advisory Database · CC BY 4.0
- CVE-2024-42005 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences