nilfs2: fix inode number range checks
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: nilfs2: fix inode number range checks Patch series "nilfs2: fix potential issues related to reserved inodes". This series fixes one use-after-free issue reported by syzbot, caused by nilfs2's internal inode being exposed in the namespace on a corrupted filesystem, and a couple of flaws that cause problems if the starting number of non-reserved inodes written in the on-disk super block is intentionally (or corruptly) changed from its default value. This patch (of 3): In the current implementation of nilfs2, "nilfs->ns_first_ino", which gives the first non-reserved inode number, is read from the superblock, but its lower limit is not checked. As a result, if a number that overlaps with the inode number range of reserved inodes such as the root directory or metadata files is set in the super block parameter, the inode number test macros (NILFS_MDT_INODE and NILFS_VALID_INODE) will not function properly. In addition, these test macros use left bit-shift calculations using with the inode number as the shift count via the BIT macro, but the result of a shift calculation that exceeds the bit width of an integer is undefined in the C specification, so if "ns_first_ino" is set to a large value other than the default value NILFS_USER_INO (=11), the macros may potentially malfunction depending on the environment. Fix these issues by checking the lower bound of "nilfs->ns_first_ino" and by preventing bit shifts equal to or greater than the NILFS_USER_INO constant in the inode number test macros. Also, change the type of "ns_first_ino" from signed integer to unsigned integer to avoid the need for type casting in comparisons such as the lower bound check introduced this time.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.30 and later | 4.19.318, 5.4.280, 5.10.222, 5.15.163, 6.1.98, 6.6.39, 6.9.9, 6.10 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.30 and later Fixed in 4.19.318, 5.4.280, 5.10.222, 5.15.163, 6.1.98, 6.6.39, 6.9.9, 6.10 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 4.19.318; 4.20 to before 5.4.280; 5.5 to before 5.10.222; 5.11 to before 5.15.163; 5.16 to before 6.1.98; 6.2 to before 6.6.39; 6.7 to before 6.9.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc1:*:*:*:*:*:* | 6.10 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc2:*:*:*:*:*:* | 6.10 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc3:*:*:*:*:*:* | 6.10 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc4:*:*:*:*:*:* | 6.10 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc5:*:*:*:*:*:* | 6.10 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.10:rc6:*:*:*:*:*:* | 6.10 rc6 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.19.318; 4.20 to before 5.4.280; 5.5 to before 5.10.222; 5.11 to before 5.15.163; 5.16 to before 6.1.98; 6.2 to before 6.6.39; 6.7 to before 6.9.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc1:*:*:*:*:*:* Versions 6.10 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc2:*:*:*:*:*:* Versions 6.10 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc3:*:*:*:*:*:* Versions 6.10 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc4:*:*:*:*:*:* Versions 6.10 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc5:*:*:*:*:*:* Versions 6.10 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.10:rc6:*:*:*:*:*:* Versions 6.10 rc6 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.318, 5.4.280, 5.10.222, 5.15.163, 6.1.98, 6.6.39, 6.9.9, 6.10
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-42105
- 2026-10-03 Alias added: GHSA-875j-57vx-426c
References
Patch 8
- https://git.kernel.org/stable/c/57235c3c88bb430043728d0d02f44a4efe386476
- https://git.kernel.org/stable/c/08cab183a624ba71603f3754643ae11cab34dbc4
- https://git.kernel.org/stable/c/731011ac6c37cbe97ece229fc6daa486276052c5
- https://git.kernel.org/stable/c/3be4dcc8d7bea52ea41f87aa4bbf959efe7a5987
- https://git.kernel.org/stable/c/fae1959d6ab2c52677b113935e36ab4e25df37ea
- https://git.kernel.org/stable/c/9194f8ca57527958bee207919458e372d638d783
- https://git.kernel.org/stable/c/1c91058425a01131ea30dda6cf43c67b17884d6a
- https://git.kernel.org/stable/c/e2fec219a36e0993642844be0f345513507031f4
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-42105 · CVE Program
- CVE-2024-42105 · NVD
- FIRST EPSS
- GHSA-875j-57vx-426c · GitHub Advisory Database · CC BY 4.0
- CVE-2024-42105 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences