Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-613.
Summary
Insufficient Session Expiration vulnerability in Apache Airflow Providers FAB. This issue affects Apache Airflow Providers FAB: 1.2.1 (when used with Apache Airflow 2.9.3) and FAB 1.2.0 for all Airflow versions. The FAB provider prevented the user from logging out. * FAB provider 1.2.1 only affected Airflow 2.9.3 (earlier and later versions of Airflow are not affected) * FAB provider 1.2.0 affected all versions of Airflow. Users who run Apache Airflow 2.9.3 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue. Users who run Any Apache Airflow version and have FAB provider 1.2.0 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue. Also upgrading Apache Airflow to latest version available is recommended. Note: Early version of Airflow reference container images of Airflow 2.9.3 and constraint files contained FAB provider 1.2.1 version, but this is fixed in updated versions of the images. Users are advised to pull the latest Airflow images or reinstall FAB provider according to the current constraints.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow Providers FAB | 1.2.0 – 1.2.1 | — | No fix listed | CNA |
| — | apache-airflow-providers-fab (PyPI) | 1.2.0 to before 1.2.2 | 1.2.2 | Patch available | GHSA-62qf-qm3g-fvcw |
- Apache Airflow Providers FAB VendorApache Affected 1.2.0 – 1.2.1 Fixed in — No fix listed CNA
- apache-airflow-providers-fab (PyPI) Vendor— Affected 1.2.0 to before 1.2.2 Fixed in 1.2.2 Patch available GHSA-62qf-qm3g-fvcw
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:apache-airflow-providers-fab:1.2.1:*:*:*:*:*:*:* | 1.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:airflow:2.9.3:*:*:*:*:*:*:* | 2.9.3 | Running on | Apache |
| cpe:2.3:a:apache:apache-airflow-providers-fab:1.2.0:*:*:*:*:*:*:* | 1.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:airflow:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Apache |
- cpe:2.3:a:apache:apache-airflow-providers-fab:1.2.1:*:*:*:*:*:*:* Versions 1.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:airflow:2.9.3:*:*:*:*:*:*:* Versions 2.9.3 Running on ·Apache
- cpe:2.3:a:apache:apache-airflow-providers-fab:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:airflow:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Apache
Remediation
- Fix · GHSA-62qf-qm3g-fvcw apache-airflow-providers-fab (PyPI) Fixed in 1.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-42447
- 2026-10-03 Alias added: GHSA-62qf-qm3g-fvcw
References
Advisory 2
More Apache-airflow-providers-fab vulnerabilities
- TI-2026-56769 Insufficient session expiration in Apache Airflow FAB provider CVSS 3.1CRITICAL 9.8
- TI-2026-42383 Improper signature verification in Apache Airflow FAB provider CVSS 3.1CRITICAL 9.8
- TI-2026-59161 Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions CVSS 3.1CRITICAL 9.1
- TI-2026-52804 Origin validation error in Apache Airflow FAB provider CVSS 3.1CRITICAL 9.1
- TI-2024-30146 Apache Airflow Fab Provider: Application does not invalidate session after password change via Airflow cli CVSS 3.1HIGH 8.1
- TI-2026-42385 Improper privilege management in Apache Airflow FAB provider CVSS 3.1HIGH 8.1
Sources
- CVE-2024-42447 · CVE Program
- CVE-2024-42447 · NVD
- FIRST EPSS
- GHSA-62qf-qm3g-fvcw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences