CometVisu Backend for openHAB affected by SSRF/XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. In versions 3.4.0.M4 through 4.2.0,, the proxy endpoint of openHAB's CometVisu add-on can be accessed without authentication. This proxy-feature can be exploited as Server-Side Request Forgery (SSRF) to induce GET HTTP requests to internal-only servers, in case openHAB is exposed in a non-private network. Furthermore, this proxy-feature can also be exploited as a Cross-Site Scripting (XSS) vulnerability, as an attacker is able to re-route a request to their server and return a page with malicious JavaScript code. Since the browser receives this data directly from the openHAB CometVisu UI, this JavaScript code will be executed with the origin of the CometVisu UI. This allows an attacker to exploit call endpoints on an openHAB server even if the openHAB server is located in a private network. (e.g. by sending an openHAB admin a link that proxies malicious JavaScript.) This issue may lead up to Remote Code Execution (RCE) when chained with other vulnerabilities. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openhab | openhab-webui | 3.4.0.M4 to before 4.2.1 | 4.2.1 | Patch available | CNA |
| — | org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven) | 3.4.0.M4 to before 4.2.1 | 4.2.1 | Patch available | GHSA-v7gr-mqpj-wwh3 |
- openhab-webui Vendoropenhab Affected 3.4.0.M4 to before 4.2.1 Fixed in 4.2.1 Patch available CNA
- org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven) Vendor— Affected 3.4.0.M4 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-v7gr-mqpj-wwh3
Remediation
- Fix · CNA openhab-webui (openhab) Fixed in 4.2.1
- Fix · GHSA-v7gr-mqpj-wwh3 org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven) Fixed in 4.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-42467
- 2026-10-03 Alias added: GHSA-v7gr-mqpj-wwh3
References
Advisory 2
Other 3
- https://github.com/openhab/openhab-webui/commit/531dabfa8311a50d2e740bf4f2b4f2400e78646c#diff-b9a920cefe5f9b2ee3615cb29f88bcad0535012c2ae2535bd12e47d6d9395b6a
- https://github.com/openhab/openhab-webui/blob/1c03c60f84388b9d7da0231df2d4ebb1e17d3fcf/bundles/org.openhab.ui.cometvisu/src/main/java/org/openhab/ui/cometvisu/internal/backend/rest/ProxyResource.java#L83
- https://github.com/openhab/openhab-webui
Sources
- CVE-2024-42467 · CVE Program
- CVE-2024-42467 · NVD
- FIRST EPSS
- GHSA-v7gr-mqpj-wwh3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences