CometVisu Backend for openHAB has a sensitive information disclosure vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. Several endpoints in versions prior to 4.2.1 of the CometVisu add-on of openHAB don't require authentication. This makes it possible for unauthenticated attackers to modify or to steal sensitive data. This issue may lead to sensitive information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openhab | openhab-webui | before 4.2.1 | 4.2.1 | Patch available | CNA |
| — | org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven) | before 4.2.1 | 4.2.1 | Patch available | GHSA-3g4c-hjhr-73rj |
- openhab-webui Vendoropenhab Affected before 4.2.1 Fixed in 4.2.1 Patch available CNA
- org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven) Vendor— Affected before 4.2.1 Fixed in 4.2.1 Patch available GHSA-3g4c-hjhr-73rj
Remediation
- Fix · CNA openhab-webui (openhab) Fixed in 4.2.1
- Fix · GHSA-3g4c-hjhr-73rj org.openhab.ui.bundles:org.openhab.ui.cometvisu (Maven) Fixed in 4.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-42470
- 2026-10-03 Alias added: GHSA-3g4c-hjhr-73rj
References
More Openhab vulnerabilities
- TI-2024-28437 CometVisu Backend for openHAB affected by RCE through path traversal CVSS 3.1CRITICAL 9.8
- TI-2020-04298 openHAB exec add-ons allow remote arbitrary command execution CVSS 3.1HIGH 8.8
- TI-2024-28436 Path traversal (CometVisu) CVSS 3.1HIGH 7.5
- TI-2021-04367 XXE vulnerability in OpenHAB CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-42470 · CVE Program
- CVE-2024-42470 · NVD
- FIRST EPSS
- GHSA-3g4c-hjhr-73rj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences