authentik has Insufficient Authorization for several API endpoints
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
authentik is an open-source Identity Provider. Several API endpoints can be accessed by users without correct authentication/authorization. The main API endpoints affected by this are /api/v3/crypto/certificatekeypairs/<uuid>/view_certificate/, /api/v3/crypto/certificatekeypairs/<uuid>/view_private_key/, and /api/v3/.../used_by/. Note that all of the affected API endpoints require the knowledge of the ID of an object, which especially for certificates is not accessible to an unprivileged user. Additionally the IDs for most objects are UUIDv4, meaning they are not easily guessable/enumerable. authentik 2024.4.4, 2024.6.4 and 2024.8.0 fix this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| goauthentik | authentik | before 2024.4.4; 2024.6.0-rc1 to before 2024.6.4 | 2024.4.4, 2024.6.4 | Patch available | CNA |
| — | goauthentik.io (Go) | 2024.6.0-rc1 to before 2024.6.4 | 2024.6.4 | Patch available | GHSA-qxqc-27pr-wgc8 |
| — | goauthentik.io (Go) | before 2024.4.4 | 2024.4.4 | Patch available | GHSA-qxqc-27pr-wgc8 |
- authentik Vendorgoauthentik Affected before 2024.4.4; 2024.6.0-rc1 to before 2024.6.4 Fixed in 2024.4.4, 2024.6.4 Patch available CNA
- goauthentik.io (Go) Vendor— Affected 2024.6.0-rc1 to before 2024.6.4 Fixed in 2024.6.4 Patch available GHSA-qxqc-27pr-wgc8
- goauthentik.io (Go) Vendor— Affected before 2024.4.4 Fixed in 2024.4.4 Patch available GHSA-qxqc-27pr-wgc8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:goauthentik:authentik:*:*:*:*:*:*:*:* | before 2024.4.4; 2024.6.0 to before 2024.6.4 | Vulnerable | goauthentik |
- cpe:2.3:a:goauthentik:authentik:*:*:*:*:*:*:*:* Versions before 2024.4.4; 2024.6.0 to before 2024.6.4 Vulnerable ·goauthentik
Remediation
- Fix · CNA authentik (goauthentik) Fixed in 2024.4.4, 2024.6.4
- Fix · GHSA-qxqc-27pr-wgc8 goauthentik.io (Go) Fixed in 2024.6.4 Advisory →
- Fix · GHSA-qxqc-27pr-wgc8 goauthentik.io (Go) Fixed in 2024.4.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-42490
- 2026-10-03 Alias added: GHSA-qxqc-27pr-wgc8
References
Patch 2
Advisory 2
More goauthentik Authentik vulnerabilities
- TI-2026-36603 authentik: SourceStage bypass via empty POST CVSS 3.1CRITICAL 9.8
- TI-2022-07608 authentik vulnerable to Improper Authentication via invitation URL token reuse CVSS 3.1CRITICAL 9.4
- TI-2026-36598 authentik: `UserSourceConnection.user` and `GroupSourceConnection.group` are changeable through the API CVSS 3.1HIGH 8.8
- TI-2022-22816 authentik allows existing authenticated users to create arbitrary accounts CVSS 3.1MEDIUM 6.4
- TI-2024-25628 Insufficient access control for OAuth2 Device Code flow in authentik CVSS 3.1CRITICAL 9.8
- TI-2023-24876 authentik potential installation takeover when default admin user is deleted CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-42490 · CVE Program
- CVE-2024-42490 · NVD
- FIRST EPSS
- GHSA-qxqc-27pr-wgc8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences