Read the docs
TI-2024-29378 Aliases CVE-2024-43783GHSA-x6xq-whh3-gg32

Apollo Router Coprocessors may cause Denial-of-Service when handling request bodies

Priority MEDIUM 40CWE-770Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.

Summary

The Apollo Router Core is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Instances of the Apollo Router running versions >=1.21.0 and < 1.52.1 are impacted by a denial of service vulnerability if _all_ of the following are true: 1. The Apollo Router has been configured to support [External Coprocessing](https://www.apollographql.com/docs/router/customizations/coprocessor). 2. The Apollo Router has been configured to send request bodies to coprocessors. This is a non-default configuration and must be configured intentionally by administrators. Instances of the Apollo Router running versions >=1.7.0 and <1.52.1 are impacted by a denial-of-service vulnerability if all of the following are true: 1. Router has been configured to use a custom-developed Native Rust Plugin. 2. The plugin accesses Request.router_request in the RouterService layer. 3. You are accumulating the body from Request.router_request into memory. If using an impacted configuration, the Router will load entire HTTP request bodies into memory without respect to other HTTP request size-limiting configurations like limits.http_max_request_bytes. This can cause the Router to be out-of-memory (OOM) terminated if a sufficiently large request is sent to the Router. By default, the Router sets limits.http_max_request_bytes to 2 MB. If you have an impacted configuration as defined above, please upgrade to at least Apollo Router 1.52.1. If you cannot upgrade, you can mitigate the denial-of-service opportunity impacting External Coprocessors by setting the coprocessor.router.request.body configuration option to false. Please note that changing this configuration option will change the information sent to any coprocessors you have configured and may impact functionality implemented by those coprocessors. If you have developed a Native Rust Plugin and cannot upgrade, you can update your plugin to either not accumulate the request body or enforce a maximum body size limit. You can also mitigate this issue by limiting HTTP body payload sizes prior to the Router (e.g., in a proxy or web application firewall appliance).

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00857 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed router (apollographql): 1.52.1apollo-router (crates.io): 1.52.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
apollographqlrouter1.7.0 to before 1.52.11.52.1Patch availableCNA
—apollo-router (crates.io)1.7.0 to before 1.52.11.52.1Patch availableGHSA-x6xq-whh3-gg32
  • router Vendorapollographql Affected 1.7.0 to before 1.52.1 Fixed in 1.52.1 Patch available CNA
  • apollo-router (crates.io) Vendor— Affected 1.7.0 to before 1.52.1 Fixed in 1.52.1 Patch available GHSA-x6xq-whh3-gg32

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:apollographql:apollo-router:*:*:*:*:*:rust:*:*1.7.0 to before 1.52.1Vulnerableapollographql
cpe:2.3:a:apollographql:apollo_helms-charts_router:*:*:*:*:*:*:*:*1.7.0 to before 1.52.1Vulnerableapollographql
cpe:2.3:a:apollographql:apollo_router:*:*:*:*:*:*:*:*1.7.0 to before 1.52.1Vulnerableapollographql
  • cpe:2.3:a:apollographql:apollo-router:*:*:*:*:*:rust:*:* Versions 1.7.0 to before 1.52.1 Vulnerable ·apollographql
  • cpe:2.3:a:apollographql:apollo_helms-charts_router:*:*:*:*:*:*:*:* Versions 1.7.0 to before 1.52.1 Vulnerable ·apollographql
  • cpe:2.3:a:apollographql:apollo_router:*:*:*:*:*:*:*:* Versions 1.7.0 to before 1.52.1 Vulnerable ·apollographql

Remediation

  • Fix · CNA router (apollographql) Fixed in 1.52.1
  • Fix · GHSA-x6xq-whh3-gg32 apollo-router (crates.io) Fixed in 1.52.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-43783
  2. 2026-10-03 Alias added: GHSA-x6xq-whh3-gg32

References

  • TI-2024-29063 Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries CVSS 3.1HIGH 7.5

Sources