fuse: Initialize beyond-EOF page contents before setting uptodate
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 5 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: fuse: Initialize beyond-EOF page contents before setting uptodate fuse_notify_store(), unlike fuse_do_readpage(), does not enable page zeroing (because it can be used to change partial page contents). So fuse_notify_store() must be more careful to fully initialize page contents (including parts of the page that are beyond end-of-file) before marking the page uptodate. The current code can leave beyond-EOF page contents uninitialized, which makes these uninitialized page contents visible to userspace via mmap(). This is an information leak, but only affects systems which do not enable init-on-alloc (via CONFIG_INIT_ON_ALLOC_DEFAULT_ON=y or the corresponding kernel command line parameter).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.36 and later | 4.19.321, 5.4.283, 5.10.225, 5.15.166, 6.1.107, 6.6.48, 6.10.7, 6.11 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.36 and later Fixed in 4.19.321, 5.4.283, 5.10.225, 5.15.166, 6.1.107, 6.6.48, 6.10.7, 6.11 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.36 to before 4.19.321; 4.20 to before 5.4.283; 5.5 to before 5.10.225; 5.11 to before 5.15.166; 5.16 to before 6.1.107; 6.2 to before 6.6.48; 6.7 to before 6.10.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc1:*:*:*:*:*:* | 6.11 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* | 6.11 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* | 6.11 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.36 to before 4.19.321; 4.20 to before 5.4.283; 5.5 to before 5.10.225; 5.11 to before 5.15.166; 5.16 to before 6.1.107; 6.2 to before 6.6.48; 6.7 to before 6.10.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc1:*:*:*:*:*:* Versions 6.11 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* Versions 6.11 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* Versions 6.11 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.321, 5.4.283, 5.10.225, 5.15.166, 6.1.107, 6.6.48, 6.10.7, 6.11
Red Hat 1 advisory
- RHSA-2024:9315 Released 2024-11-12 · Red Hat rating Moderatekernel security update
- Red Hat CodeReady Linux Builder (v. 9) kernel-cross-headers-5.14.0-503.11.1.el9_5, kernel-tools-libs-devel-5.14.0-503.11.1.el9_5, libperf-5.14.0-503.11.1.el9_5
- Red Hat Enterprise Linux AppStream (v. 9) kernel-64k-debug-devel-5.14.0-503.11.1.el9_5, kernel-64k-debug-devel-matched-5.14.0-503.11.1.el9_5, kernel-64k-devel-5.14.0-503.11.1.el9_5 +12
- Red Hat Enterprise Linux BaseOS (v. 9) bpftool-7.4.0-503.11.1.el9_5, kernel-5.14.0-503.11.1.el9_5, kernel-64k-5.14.0-503.11.1.el9_5 +30
- Red Hat Enterprise Linux Real Time (v. 9) kernel-rt-5.14.0-503.11.1.el9_5, kernel-rt-core-5.14.0-503.11.1.el9_5, kernel-rt-debug-5.14.0-503.11.1.el9_5 +9
- Red Hat Enterprise Linux Real Time for NFV (v. 9) kernel-rt-5.14.0-503.11.1.el9_5, kernel-rt-core-5.14.0-503.11.1.el9_5, kernel-rt-debug-5.14.0-503.11.1.el9_5 +11
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2024:9315 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:9315 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2024:9315 |
| Red Hat Enterprise Linux Real Time (v. 9) | Fixed | RHSA-2024:9315 |
| Red Hat Enterprise Linux Real Time for NFV (v. 9) | Fixed | RHSA-2024:9315 |
Not affected: 2 products
- Red Hat CodeReady Linux Builder (v. 9)
- Red Hat Enterprise Linux AppStream (v. 9)
Timeline
- 2026-10-02 Threatist record created from CVE-2024-44947
- 2026-10-03 Alias added: GHSA-xjwh-3rm6-w25h
- 2026-10-29 Affected versions changed · Red Hat
References
Patch 8
- https://git.kernel.org/stable/c/49934861514d36d0995be8e81bb3312a499d8d9a
- https://git.kernel.org/stable/c/33168db352c7b56ae18aa55c2cae1a1c5905d30e
- https://git.kernel.org/stable/c/4690e2171f651e2b415e3941ce17f2f7b813aff6
- https://git.kernel.org/stable/c/8c78303eafbf85a728dd84d1750e89240c677dd9
- https://git.kernel.org/stable/c/831433527773e665bdb635ab5783d0b95d1246f4
- https://git.kernel.org/stable/c/ac42e0f0eb66af966015ee33fd355bc6f5d80cd6
- https://git.kernel.org/stable/c/18a067240817bee8a9360539af5d79a4bf5398a5
- https://git.kernel.org/stable/c/3c0da3d163eb32f1f91891efaade027fa9b245b9
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-44947 · CVE Program
- CVE-2024-44947 · NVD
- FIRST EPSS
- GHSA-xjwh-3rm6-w25h · GitHub Advisory Database · CC BY 4.0
- CVE-2024-44947 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences