binfmt_flat: Fix corruption when not offsetting data start
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: binfmt_flat: Fix corruption when not offsetting data start Commit 04d82a6d0881 ("binfmt_flat: allow not offsetting data start") introduced a RISC-V specific variant of the FLAT format which does not allocate any space for the (obsolete) array of shared library pointers. However, it did not disable the code which initializes the array, resulting in the corruption of sizeof(long) bytes before the DATA segment, generally the end of the TEXT segment. Introduce MAX_SHARED_LIBS_UPDATE which depends on the state of CONFIG_BINFMT_FLAT_NO_DATA_START_OFFSET to guard the initialization of the shared library pointer region so that it will only be initialized if space is reserved for it.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.13 and later | 5.15.165, 6.1.106, 6.6.47, 6.10.6, 6.11 | Patch available | CNA |
- Linux VendorLinux Affected 5.13 and later Fixed in 5.15.165, 6.1.106, 6.6.47, 6.10.6, 6.11 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.13 to before 5.15.165; 5.16 to before 6.1.106; 6.2 to before 6.6.47; 6.7 to before 6.10.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc1:*:*:*:*:*:* | 6.11 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* | 6.11 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* | 6.11 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.13 to before 5.15.165; 5.16 to before 6.1.106; 6.2 to before 6.6.47; 6.7 to before 6.10.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc1:*:*:*:*:*:* Versions 6.11 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* Versions 6.11 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* Versions 6.11 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.15.165, 6.1.106, 6.6.47, 6.10.6, 6.11
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-44966
- 2026-10-03 Alias added: GHSA-g9qh-hcq6-2x9p
References
Patch 5
- https://git.kernel.org/stable/c/3a684499261d0f7ed5ee72793025c88c2276809c
- https://git.kernel.org/stable/c/af65d5383854cc3f172a7d0843b628758bf462c8
- https://git.kernel.org/stable/c/49df34d2b7da9e57c839555a2f7877291ce45ad1
- https://git.kernel.org/stable/c/9350ba06ee61db392c486716ac68ecc20e030f7c
- https://git.kernel.org/stable/c/3eb3cd5992f7a0c37edc8d05b4c38c98758d8671
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-44966 · CVE Program
- CVE-2024-44966 · NVD
- FIRST EPSS
- GHSA-g9qh-hcq6-2x9p · GitHub Advisory Database · CC BY 4.0
- CVE-2024-44966 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences