Arbitrary language parameter can passed to `aspell` executable via spelling requests in overleaf
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
Overleaf is a web-based collaborative LaTeX editor. Overleaf Community Edition and Server Pro prior to version 5.0.7 (or 4.2.7 for the 4.x series) contain a vulnerability that allows an arbitrary language parameter in client spelling requests to be passed to the `aspell` executable running on the server. This causes `aspell` to attempt to load a dictionary file with an arbitrary filename. File access is limited to the scope of the overleaf server. The problem is patched in versions 5.0.7 and 4.2.7. Previous versions can be upgraded using the Overleaf toolkit `bin/upgrade` command. Users unable to upgrade may block POST requests to `/spelling/check` via a Web Application Firewall will prevent access to the vulnerable spell check feature. However, upgrading is advised.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| overleaf | overleaf | 4.0.0 to before 4.2.7; 5.0.0 to before 5.0.7 | 4.2.7, 5.0.7 | Patch available | CNA |
- overleaf Vendoroverleaf Affected 4.0.0 to before 4.2.7; 5.0.0 to before 5.0.7 Fixed in 4.2.7, 5.0.7 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:overleaf:overleaf:*:*:*:*:community:*:*:* | 4.0.0 to before 4.2.7 | Vulnerable | overleaf |
| cpe:2.3:a:overleaf:overleaf:*:*:server_pro:*:*:*:*:* | 4.0.0 to before 4.2.7 | Vulnerable | overleaf |
| cpe:2.3:a:overleaf:overleaf:*:*:*:*:community:*:*:* | 5.0.0 to before 5.0.7 | Vulnerable | overleaf |
| cpe:2.3:a:overleaf:overleaf:*:*:server_pro:*:*:*:*:* | 5.0.0 to before 5.0.7 | Vulnerable | overleaf |
- cpe:2.3:a:overleaf:overleaf:*:*:*:*:community:*:*:* Versions 4.0.0 to before 4.2.7 Vulnerable ·overleaf
- cpe:2.3:a:overleaf:overleaf:*:*:server_pro:*:*:*:*:* Versions 4.0.0 to before 4.2.7 Vulnerable ·overleaf
- cpe:2.3:a:overleaf:overleaf:*:*:*:*:community:*:*:* Versions 5.0.0 to before 5.0.7 Vulnerable ·overleaf
- cpe:2.3:a:overleaf:overleaf:*:*:server_pro:*:*:*:*:* Versions 5.0.0 to before 5.0.7 Vulnerable ·overleaf
Remediation
- Fix · CNA overleaf (overleaf) Fixed in 4.2.7, 5.0.7
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45312
References
More Overleaf vulnerabilities
- TI-2024-30384 Insecure default setting for Server Pro installed via Overleaf toolkit CVSS 3.1MEDIUM 5.4
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences