@blakeembrey/template vulnerable to code injection when attacker controls template input
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
@blakeembrey/template is a string template library. Prior to version 1.2.0, it is possible to inject and run code within the template if the attacker has access to write the template name. Version 1.2.0 contains a patch. As a workaround, don't pass untrusted input as the template display name, or don't use the display name feature.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| blakeembrey | js-template | before 1.2.0 | 1.2.0 | Patch available | CNA |
| — | @blakeembrey/template (npm) | before 1.2.0 | 1.2.0 | Patch available | GHSA-q765-wm9j-66qj |
- js-template Vendorblakeembrey Affected before 1.2.0 Fixed in 1.2.0 Patch available CNA
- @blakeembrey/template (npm) Vendor— Affected before 1.2.0 Fixed in 1.2.0 Patch available GHSA-q765-wm9j-66qj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:blakeembrey:template:*:*:*:*:*:node.js:*:* | before 1.2.0 | Vulnerable | blakeembrey |
- cpe:2.3:a:blakeembrey:template:*:*:*:*:*:node.js:*:* Versions before 1.2.0 Vulnerable ·blakeembrey
Remediation
- Fix · CNA js-template (blakeembrey) Fixed in 1.2.0
- Fix · GHSA-q765-wm9j-66qj @blakeembrey/template (npm) Fixed in 1.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45390
- 2026-10-03 Alias added: GHSA-q765-wm9j-66qj
References
Sources
- CVE-2024-45390 · CVE Program
- CVE-2024-45390 · NVD
- FIRST EPSS
- GHSA-q765-wm9j-66qj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences