Secret encryption vulnerable to brute-force attacks
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-327.
Summary
Authenticator is a browser extension that generates two-step verification codes. In versions 7.0.0 and below, encryption keys for user data were stored encrypted at-rest using only AES-256 and the EVP_BytesToKey KDF. Therefore, attackers with a copy of a user's data are able to brute-force the user's encryption key. Users on version 8.0.0 and above are automatically migrated away from the weak encoding on first login. Users should destroy encrypted backups made with versions prior to 8.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Authenticator-Extension | Authenticator | before 8.0.0 | 8.0.0 | Patch available | CNA |
- Authenticator VendorAuthenticator-Extension Affected before 8.0.0 Fixed in 8.0.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:authenticator:authenticator:*:*:*:*:*:*:*:* | before 8.0.0 | Vulnerable | Authenticator |
- cpe:2.3:a:authenticator:authenticator:*:*:*:*:*:*:*:* Versions before 8.0.0 Vulnerable ·Authenticator
Remediation
- Fix · CNA Authenticator (Authenticator-Extension) Fixed in 8.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45394
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences