Apache NiFi: Improper Neutralization of Input in Parameter Description
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Apache NiFi 1.10.0 through 1.27.0 and 2.0.0-M1 through 2.0.0-M3 support a description field for Parameters in a Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.28.0 or 2.0.0-M4 is the recommended mitigation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | 1.10.0 – 1.27.0; 2.0.0-M1 – 2.0.0-M3 | — | No fix listed | CNA |
| — | org.apache.nifi:nifi-web-ui (Maven) | 1.10.0 to before 1.28.0 | 1.28.0 | Patch available | GHSA-7mqj-xgf8-p59v |
| — | org.apache.nifi:nifi-web-ui (Maven) | 2.0.0-M1 to before 2.0.0-M4 | 2.0.0-M4 | Patch available | GHSA-7mqj-xgf8-p59v |
- Apache NiFi VendorApache Affected 1.10.0 – 1.27.0; 2.0.0-M1 – 2.0.0-M3 Fixed in — No fix listed CNA
- org.apache.nifi:nifi-web-ui (Maven) Vendor— Affected 1.10.0 to before 1.28.0 Fixed in 1.28.0 Patch available GHSA-7mqj-xgf8-p59v
- org.apache.nifi:nifi-web-ui (Maven) Vendor— Affected 2.0.0-M1 to before 2.0.0-M4 Fixed in 2.0.0-M4 Patch available GHSA-7mqj-xgf8-p59v
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* | 1.10.0 – 1.27.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone1:*:*:*:*:*:* | 2.0.0 milestone1 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone2:*:*:*:*:*:* | 2.0.0 milestone2 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone3:*:*:*:*:*:* | 2.0.0 milestone3 | Vulnerable | Apache |
- cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* Versions 1.10.0 – 1.27.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone1:*:*:*:*:*:* Versions 2.0.0 milestone1 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone2:*:*:*:*:*:* Versions 2.0.0 milestone2 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone3:*:*:*:*:*:* Versions 2.0.0 milestone3 Vulnerable ·Apache
Remediation
- Fix · GHSA-7mqj-xgf8-p59v org.apache.nifi:nifi-web-ui (Maven) Fixed in 1.28.0 Advisory →
- Fix · GHSA-7mqj-xgf8-p59v org.apache.nifi:nifi-web-ui (Maven) Fixed in 2.0.0-M4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45477
- 2026-10-03 Alias added: GHSA-7mqj-xgf8-p59v
References
Advisory 2
Other 6
- https://github.com/apache/nifi/pull/9195
- https://github.com/apache/nifi/commit/153c87a7daaeebea9b119066285b840ea4056e09
- https://github.com/apache/nifi
- https://github.com/apache/nifi/blob/rel/nifi-1.27.0/nifi-nar-bundles/nifi-framework-bundle/nifi-framework/nifi-web/nifi-web-ui/src/main/webapp/js/nf/canvas/nf-parameter-contexts.js#L2197
- https://issues.apache.org/jira/browse/NIFI-13675
- https://nifi.apache.org/documentation/security/#CVE-2024-45477
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2024-45477 · CVE Program
- CVE-2024-45477 · NVD
- FIRST EPSS
- GHSA-7mqj-xgf8-p59v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences