Read the docs
TI-2024-30739 Aliases CVE-2024-45772GHSA-g643-xq6w-r67c

Apache Lucene Replicator: Security Vulnerability in Lucene Replicator - Deserialization Issue

Priority LOW 36CWE-502Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator. This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00582 48th percentileScored 2026-11-07
Fix Fixed Apache Lucene Replicator (Apache Software Foundation): 9.12.0org.apache.lucene:lucene-replicator (Maven): 9.12.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Lucene Replicator4.4.0 to before 9.12.09.12.0Patch availableCNA
—org.apache.lucene:lucene-replicator (Maven)4.4.0 to before 9.12.09.12.0Patch availableGHSA-g643-xq6w-r67c
  • Apache Lucene Replicator VendorApache Affected 4.4.0 to before 9.12.0 Fixed in 9.12.0 Patch available CNA
  • org.apache.lucene:lucene-replicator (Maven) Vendor— Affected 4.4.0 to before 9.12.0 Fixed in 9.12.0 Patch available GHSA-g643-xq6w-r67c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:lucene_replicator:*:*:*:*:*:*:*:*4.4.0 to before 9.12.0VulnerableApache
  • cpe:2.3:a:apache:lucene_replicator:*:*:*:*:*:*:*:* Versions 4.4.0 to before 9.12.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Lucene Replicator (Apache Software Foundation) Fixed in 9.12.0
  • Fix · GHSA-g643-xq6w-r67c org.apache.lucene:lucene-replicator (Maven) Fixed in 9.12.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-45772
  2. 2026-10-03 Alias added: GHSA-g643-xq6w-r67c

References

Sources