Read the docs
TI-2024-30770 Aliases CVE-2024-45803GHSA-rw5h-g8xq-6877

Cross site scripting (XSS) Vulnerability on route /wireui/button?label=Content in wireui

Priority MEDIUM 56CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Wire UI is a library of components and resources to empower Laravel and Livewire application development. A potential Cross-Site Scripting (XSS) vulnerability has been identified in the `/wireui/button` endpoint, specifically through the `label` query parameter. Malicious actors could exploit this vulnerability by injecting JavaScript into the `label` parameter, leading to the execution of arbitrary code in the victim's browser. The `/wireui/button` endpoint dynamically renders button labels based on user-provided input via the `label` query parameter. Due to insufficient sanitization or escaping of this input, an attacker can inject malicious JavaScript. By crafting such a request, an attacker can inject arbitrary code that will be executed by the browser when the endpoint is accessed. If exploited, this vulnerability could allow an attacker to execute arbitrary JavaScript code in the context of the affected website. This could lead to: **Session Hijacking**: Stealing session cookies, tokens, or other sensitive information. **User Impersonation**: Performing unauthorized actions on behalf of authenticated users. **Phishing**: Redirecting users to malicious websites. **Content Manipulation**: Altering the appearance or behavior of the affected page to mislead users or execute further attacks. The severity of this vulnerability depends on the context of where the affected component is used, but in all cases, it poses a significant risk to user security. This issue has been addressed in release versions 1.19.3 and 2.1.3. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00416 36th percentileScored 2026-11-07
Fix Fixed wireui (wireui): 1.19.3, 2.1.3wireui/wireui (Packagist): 1.19.3, 2.1.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wireuiwireuibefore 1.19.3; 2.0.0 to before 2.1.31.19.3, 2.1.3Patch availableCNA
—wireui/wireui (Packagist)before 1.19.31.19.3Patch availableGHSA-rw5h-g8xq-6877
—wireui/wireui (Packagist)2.0.0 to before 2.1.32.1.3Patch availableGHSA-rw5h-g8xq-6877
  • wireui Vendorwireui Affected before 1.19.3; 2.0.0 to before 2.1.3 Fixed in 1.19.3, 2.1.3 Patch available CNA
  • wireui/wireui (Packagist) Vendor— Affected before 1.19.3 Fixed in 1.19.3 Patch available GHSA-rw5h-g8xq-6877
  • wireui/wireui (Packagist) Vendor— Affected 2.0.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-rw5h-g8xq-6877

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wireui:wireui:*:*:*:*:*:*:*:*before 1.19.3; 2.0.0 to before 2.1.3Vulnerablewireui
  • cpe:2.3:a:wireui:wireui:*:*:*:*:*:*:*:* Versions before 1.19.3; 2.0.0 to before 2.1.3 Vulnerable ·wireui

Remediation

  • Fix · CNA wireui (wireui) Fixed in 1.19.3, 2.1.3
  • Fix · GHSA-rw5h-g8xq-6877 wireui/wireui (Packagist) Fixed in 1.19.3 Advisory →
  • Fix · GHSA-rw5h-g8xq-6877 wireui/wireui (Packagist) Fixed in 2.1.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-45803
  2. 2026-10-03 Alias added: GHSA-rw5h-g8xq-6877

References

Sources