drm/vmwgfx: Disable coherent dumb buffers without 3d
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: drm/vmwgfx: Disable coherent dumb buffers without 3d Coherent surfaces make only sense if the host renders to them using accelerated apis. Without 3d the entire content of dumb buffers stays in the guest making all of the extra work they're doing to synchronize between guest and host useless. Configurations without 3d also tend to run with very low graphics memory limits. The pinned console fb, mob cursors and graphical login manager tend to run out of 16MB graphics memory that those guests use. Fix it by making sure the coherent dumb buffers are only used on configs with 3d enabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.10.4 to before 6.10.8 | 6.10.8 | Patch available | CNA |
- Linux VendorLinux Affected 6.10.4 to before 6.10.8 Fixed in 6.10.8 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.10.4 to before 6.10.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* | 6.11 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* | 6.11 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc4:*:*:*:*:*:* | 6.11 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc5:*:*:*:*:*:* | 6.11 rc5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.10.4 to before 6.10.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* Versions 6.11 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* Versions 6.11 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc4:*:*:*:*:*:* Versions 6.11 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc5:*:*:*:*:*:* Versions 6.11 rc5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.10.8
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
Not affected: 2 products
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-46712
- 2026-10-03 Alias added: GHSA-cp7f-67pj-cxg3
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-46712 · CVE Program
- CVE-2024-46712 · NVD
- FIRST EPSS
- GHSA-cp7f-67pj-cxg3 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-46712 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences