kunit/overflow: Fix UB in overflow_allocation_test
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: kunit/overflow: Fix UB in overflow_allocation_test The 'device_name' array doesn't exist out of the 'overflow_allocation_test' function scope. However, it is being used as a driver name when calling 'kunit_driver_create' from 'kunit_device_register'. It produces the kernel panic with KASAN enabled. Since this variable is used in one place only, remove it and pass the device name into kunit_device_register directly as an ascii string.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.8 and later | 6.10.10, 6.11 | Patch available | CNA |
- Linux VendorLinux Affected 6.8 and later Fixed in 6.10.10, 6.11 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 6.10.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc1:*:*:*:*:*:* | 6.11 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* | 6.11 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* | 6.11 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 6.10.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc1:*:*:*:*:*:* Versions 6.11 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* Versions 6.11 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* Versions 6.11 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.10.10, 6.11
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-46823
- 2026-10-03 Alias added: GHSA-hm28-rwr4-j8f5
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-46823 · CVE Program
- CVE-2024-46823 · NVD
- FIRST EPSS
- GHSA-hm28-rwr4-j8f5 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-46823 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences