perf/x86/intel: Limit the period on Haswell
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: perf/x86/intel: Limit the period on Haswell Running the ltp test cve-2015-3290 concurrently reports the following warnings. perfevents: irq loop stuck! WARNING: CPU: 31 PID: 32438 at arch/x86/events/intel/core.c:3174 intel_pmu_handle_irq+0x285/0x370 Call Trace: <NMI> ? __warn+0xa4/0x220 ? intel_pmu_handle_irq+0x285/0x370 ? __report_bug+0x123/0x130 ? intel_pmu_handle_irq+0x285/0x370 ? __report_bug+0x123/0x130 ? intel_pmu_handle_irq+0x285/0x370 ? report_bug+0x3e/0xa0 ? handle_bug+0x3c/0x70 ? exc_invalid_op+0x18/0x50 ? asm_exc_invalid_op+0x1a/0x20 ? irq_work_claim+0x1e/0x40 ? intel_pmu_handle_irq+0x285/0x370 perf_event_nmi_handler+0x3d/0x60 nmi_handle+0x104/0x330 Thanks to Thomas Gleixner's analysis, the issue is caused by the low initial period (1) of the frequency estimation algorithm, which triggers the defects of the HW, specifically erratum HSW11 and HSW143. (For the details, please refer https://lore.kernel.org/lkml/87plq9l5d2.ffs@tglx/) The HSW11 requires a period larger than 100 for the INST_RETIRED.ALL event, but the initial period in the freq mode is 1. The erratum is the same as the BDM11, which has been supported in the kernel. A minimum period of 128 is enforced as well on HSW. HSW143 is regarding that the fixed counter 1 may overcount 32 with the Hyper-Threading is enabled. However, based on the test, the hardware has more issues than it tells. Besides the fixed counter 1, the message 'interrupt took too long' can be observed on any counter which was armed with a period < 32 and two events expired in the same NMI. A minimum period of 32 is enforced for the rest of the events. The recommended workaround code of the HSW143 is not implemented. Because it only addresses the issue for the fixed counter. It brings extra overhead through extra MSR writing. No related overcounting issue has been reported so far.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.11 and later | 6.1.110, 6.6.51, 6.10.10, 6.11 | Patch available | CNA |
- Linux VendorLinux Affected 3.11 and later Fixed in 6.1.110, 6.6.51, 6.10.10, 6.11 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.11 to before 6.1.110; 6.2 to before 6.6.51; 6.7 to before 6.10.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc1:*:*:*:*:*:* | 6.11 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* | 6.11 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* | 6.11 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc4:*:*:*:*:*:* | 6.11 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc5:*:*:*:*:*:* | 6.11 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc6:*:*:*:*:*:* | 6.11 rc6 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.11 to before 6.1.110; 6.2 to before 6.6.51; 6.7 to before 6.10.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc1:*:*:*:*:*:* Versions 6.11 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc2:*:*:*:*:*:* Versions 6.11 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc3:*:*:*:*:*:* Versions 6.11 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc4:*:*:*:*:*:* Versions 6.11 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc5:*:*:*:*:*:* Versions 6.11 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc6:*:*:*:*:*:* Versions 6.11 rc6 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.110, 6.6.51, 6.10.10, 6.11
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-46848
- 2026-10-03 Alias added: GHSA-f8x4-897j-jj7g
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-46848 · CVE Program
- CVE-2024-46848 · NVD
- FIRST EPSS
- GHSA-f8x4-897j-jj7g · GitHub Advisory Database · CC BY 4.0
- CVE-2024-46848 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences