Incorrect permission assignment in gradle Enterprise
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Develocity (formerly Gradle Enterprise) before 2024.1.8 has Incorrect Access Control. Project-level access control configuration was introduced in Enterprise Config schema version 8. Migration functionality from schema version 8 to versions 9 and 10 (in affected vulnerable versions) does not include the projects section of the configuration. This leads to all of the project settings being reset to their defaults when the old schema is loaded. In the case of projects.enabled, the default is false. Thus, using an enterprise config v8 results in Project level access control being disabled, even if it was previously enabled, and previously restricted project information disclosed. Most commonly, this occurs when a Develocity instance is upgraded from an earlier version. Specifically, this occurs if: Develocity 2023.3.X is upgraded to 2023.4.X; Develocity 2023.3.X is upgraded to 2024.1.X up to and including 2024.1.7; or Develocity 2023.4.X is upgraded to 2024.1.X up to and including 2024.1.7. The flaw does not occur when upgrading to a fixed version. An upgrade can only be triggered via administrator access, and cannot be forced by an external attacker.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Enterprise (Gradle) Fixed in 2024.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-46881
- 2026-10-03 Alias added: GHSA-cw76-h7wr-rh77
References
More gradle vulnerabilities
- TI-2023-26881 In Gradle Enterprise before 2023.1, a remote attacker may be able to gain access to a new… CVSS 3.1CRITICAL 9.8
- TI-2016-05320 ObjectSocketWrapper.java in Gradle 2.12 allows remote attackers to execute arbitrary code… CVSS 3.0CRITICAL 9.8
- TI-2020-09639 Injection in Apache Ant CVSS 3.1HIGH 7.5
- TI-2021-18320 In Gradle Enterprise before 2021.3 (and Enterprise Build Cache Node before 10.0), there… CVSS 3.1CRITICAL 9.8
- TI-2019-11237 The HTTP client in Gradle before 5.6 sends authentication credentials originally destined… CVSS 3.1CRITICAL 9.8
- TI-2022-10790 Gradle Enterprise before 2022.1 allows remote code execution if the installation process… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-46881 · CVE Program
- CVE-2024-46881 · NVD
- FIRST EPSS
- GHSA-cw76-h7wr-rh77 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences