Read the docs
TI-2024-31551 Aliases CVE-2024-47184

Ampache vulnerable to Stored XSS via Democratic Playlist Name

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Ampache is a web based audio/video streaming application and file manager. Prior to version 6.6.0, the Democratic Playlist Name is vulnerable to a stored cross-site scripting. Version 6.6.0 fixes this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0055 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ampache (ampache): 6.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ampacheampachebefore 6.6.06.6.0Patch availableCNA
  • ampache Vendorampache Affected before 6.6.0 Fixed in 6.6.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ampache:ampache:*:*:*:*:*:*:*:*before 6.6.0Vulnerableampache
  • cpe:2.3:a:ampache:ampache:*:*:*:*:*:*:*:* Versions before 6.6.0 Vulnerable ·ampache

Remediation

  • Fix · CNA ampache (ampache) Fixed in 6.6.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-47184

References

  • TI-2023-00731 SQL Injection in ampache/ampache CVSS 3.1HIGH 8.8
  • TI-2022-04263 Unrestricted Upload of File with Dangerous Type in ampache/ampache CVSS 3.1HIGH 8.8
  • TI-2024-32095 Cross-Site Request Forgery in ampache CVSS 3.1MEDIUM 6.5
  • TI-2023-00573 Cross-site Scripting (XSS) - Reflected in ampache/ampache CVSS 3.1MEDIUM 6.1
  • TI-2024-19055 Ampache Stored XSS CVSS 3.1MEDIUM 5.9
  • TI-2024-19054 Ampache has multiple reflective XSS vulnerabilities CVSS 3.1MEDIUM 6.1
See all 24 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences