Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Filament is a collection of full-stack components for Laravel development. Versions of Filament from v3.0.0 through v3.2.114 are affected by a cross-site scripting (XSS) vulnerability. If values passed to a `ColorColumn` or `ColumnEntry` are not valid and contain a specific set of characters, applications are vulnerable to XSS attack against a user who opens a page on which a color column or entry is rendered. Filament v3.2.115 fixes this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| filamentphp | filament | 3.0.0 to before 3.2.115 | 3.2.115 | Patch available | CNA |
| — | filament/tables (Packagist) | 3.0.0 to before 3.2.115 | 3.2.115 | Patch available | GHSA-9h9q-qhxg-89xr |
| — | filament/infolists (Packagist) | 3.0.0 to before 3.2.115 | 3.2.115 | Patch available | GHSA-9h9q-qhxg-89xr |
- filament Vendorfilamentphp Affected 3.0.0 to before 3.2.115 Fixed in 3.2.115 Patch available CNA
- filament/tables (Packagist) Vendor— Affected 3.0.0 to before 3.2.115 Fixed in 3.2.115 Patch available GHSA-9h9q-qhxg-89xr
- filament/infolists (Packagist) Vendor— Affected 3.0.0 to before 3.2.115 Fixed in 3.2.115 Patch available GHSA-9h9q-qhxg-89xr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:filamentphp:filament:*:*:*:*:*:*:*:* | 3.0.0 to before 3.2.115 | Vulnerable | filamentphp |
- cpe:2.3:a:filamentphp:filament:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.2.115 Vulnerable ·filamentphp
Remediation
- Fix · CNA filament (filamentphp) Fixed in 3.2.115
- Fix · GHSA-9h9q-qhxg-89xr filament/tables (Packagist) Fixed in 3.2.115 Advisory →
- Fix · GHSA-9h9q-qhxg-89xr filament/infolists (Packagist) Fixed in 3.2.115 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47186
- 2026-10-03 Alias added: GHSA-9h9q-qhxg-89xr
References
More filamentphp Filament vulnerabilities
- TI-2025-41263 Filament's multi-factor authentication (app) recovery codes can be used multiple times CVSS 3.1HIGH 8.1
- TI-2026-25522 Filament: Unvalidated Range and Values summarizer values can be used for XSS CVSS 3.1HIGH 7.3
Sources
- CVE-2024-47186 · CVE Program
- CVE-2024-47186 · NVD
- FIRST EPSS
- GHSA-9h9q-qhxg-89xr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences