Improper input validation in Dell Client Platform BIOS
Priority LOW 34CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Dell Client Platform BIOS contains an Improper Input Validation vulnerability in an externally developed component. A high privileged attacker with local access could potentially exploit this vulnerability, leading to arbitrary code execution.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00224 13th percentileScored 2026-11-07
Fix Fixed Dell Client Platform BIOS (Dell): 1.29.0, 1.19.0, 1.25.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Dell Client Platform BIOS | N/A to before 1.29.0; N/A to before 1.19.0; N/A to before 1.25.0 | 1.29.0, 1.19.0, 1.25.0 | Patch available | CNA |
- Dell Client Platform BIOS VendorDell Affected N/A to before 1.29.0; N/A to before 1.19.0; N/A to before 1.25.0 Fixed in 1.29.0, 1.19.0, 1.25.0 Patch available CNA
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:embedded_box_pc_3000_firmware:*:*:*:*:*:*:*:* | before 1.25.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:embedded_box_pc_3000:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:edge_gateway_3001_firmware:*:*:*:*:*:*:*:* | before 1.19.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:edge_gateway_3001:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:edge_gateway_3002_firmware:*:*:*:*:*:*:*:* | before 1.19.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:edge_gateway_3002:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:edge_gateway_3003_firmware:*:*:*:*:*:*:*:* | before 1.19.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:edge_gateway_3003:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:edge_gateway_5000_firmware:*:*:*:*:*:*:*:* | before 1.29.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:edge_gateway_5000:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:embedded_box_pc_3000_firmware:*:*:*:*:*:*:*:* Versions before 1.25.0 Vulnerable ·Dell
- cpe:2.3:h:dell:embedded_box_pc_3000:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:edge_gateway_3001_firmware:*:*:*:*:*:*:*:* Versions before 1.19.0 Vulnerable ·Dell
- cpe:2.3:h:dell:edge_gateway_3001:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:edge_gateway_3002_firmware:*:*:*:*:*:*:*:* Versions before 1.19.0 Vulnerable ·Dell
- cpe:2.3:h:dell:edge_gateway_3002:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:edge_gateway_3003_firmware:*:*:*:*:*:*:*:* Versions before 1.19.0 Vulnerable ·Dell
- cpe:2.3:h:dell:edge_gateway_3003:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:edge_gateway_5000_firmware:*:*:*:*:*:*:*:* Versions before 1.29.0 Vulnerable ·Dell
- cpe:2.3:h:dell:edge_gateway_5000:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:edge_gateway_5100_firmware:*:*:*:*:*:*:*:* | before 1.29.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:edge_gateway_5100:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:edge_gateway_3000_firmware:*:*:*:*:*:*:*:* | before 1.19.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:edge_gateway_3000:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:edge_gateway_3200_firmware:*:*:*:*:*:*:*:* | before 1.19.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:edge_gateway_3200:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:edge_gateway_5100_firmware:*:*:*:*:*:*:*:* Versions before 1.29.0 Vulnerable ·Dell
- cpe:2.3:h:dell:edge_gateway_5100:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:edge_gateway_3000_firmware:*:*:*:*:*:*:*:* Versions before 1.19.0 Vulnerable ·Dell
- cpe:2.3:h:dell:edge_gateway_3000:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:edge_gateway_3200_firmware:*:*:*:*:*:*:*:* Versions before 1.19.0 Vulnerable ·Dell
- cpe:2.3:h:dell:edge_gateway_3200:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA Dell Client Platform BIOS (Dell) Fixed in 1.29.0, 1.19.0, 1.25.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47238
- 2026-10-03 Alias added: GHSA-w6w4-cwx3-j2qh
References
More Dell Edge Gateway 3000 Firmware vulnerabilities
- TI-2022-14131 Improper input validation in Dell CPG BIOS CVSS 3.1HIGH 8.2
- TI-2022-14130 Improper input validation in Dell CPG BIOS CVSS 3.1HIGH 8.2
- TI-2022-10105 Dell BIOS versions contain an Insecure Automated Optimization vulnerability. CVSS 3.1HIGH 7.9
- TI-2022-14135 Stack-based buffer overflow in Dell CPG BIOS CVSS 3.1HIGH 7.8
- TI-2022-14132 Improper input validation in Dell BIOS CVSS 3.1HIGH 7.8
- TI-2022-14129 Improper input validation in Dell CPG BIOS CVSS 3.1HIGH 7.8
Sources
- CVE-2024-47238 · CVE Program
- CVE-2024-47238 · NVD
- FIRST EPSS
- GHSA-w6w4-cwx3-j2qh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences