PCI: kirin: Fix buffer overflow in kirin_pcie_parse_port()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-120 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: PCI: kirin: Fix buffer overflow in kirin_pcie_parse_port() Within kirin_pcie_parse_port(), the pcie->num_slots is compared to pcie->gpio_id_reset size (MAX_PCI_SLOTS) which is correct and would lead to an overflow. Thus, fix condition to pcie->num_slots + 1 >= MAX_PCI_SLOTS and move pcie->num_slots increment below the if-statement to avoid out-of-bounds array access. Found by Linux Verification Center (linuxtesting.org) with SVACE. [kwilczynski: commit log]
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.16 and later | 6.1.113, 6.6.54, 6.10.13, 6.11.2, 6.12 | Patch available | CNA |
- Linux VendorLinux Affected 5.16 and later Fixed in 6.1.113, 6.6.54, 6.10.13, 6.11.2, 6.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.16 to before 6.1.113; 6.2 to before 6.6.54; 6.7 to before 6.10.13; 6.11 to before 6.11.2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.16 to before 6.1.113; 6.2 to before 6.6.54; 6.7 to before 6.10.13; 6.11 to before 6.11.2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.113, 6.6.54, 6.10.13, 6.11.2, 6.12
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47751
- 2026-10-03 Alias added: GHSA-grr9-pcqm-fmr6
References
Patch 5
- https://git.kernel.org/stable/c/a5f795f9412854df28e66679c5e6b68b0b79c229
- https://git.kernel.org/stable/c/95248d7497bcbfe7deed4805469c6ff6ddd7f9d1
- https://git.kernel.org/stable/c/6dcc5b49d6607a741a14122bf3105f3ac50d259e
- https://git.kernel.org/stable/c/aeb0335971806e15ac91e838ca471936c8e7efd5
- https://git.kernel.org/stable/c/c500a86693a126c9393e602741e348f80f1b0fc5
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-47751 · CVE Program
- CVE-2024-47751 · NVD
- FIRST EPSS
- GHSA-grr9-pcqm-fmr6 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-47751 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences