Read the docs
TI-2024-32031 Aliases CVE-2024-47756GHSA-fw6v-6fqv-jxv4

PCI: keystone: Fix if-statement expression in ks_pcie_quirk()

Priority LOW 24CWE-476Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-476.

Summary

In the Linux kernel, the following vulnerability has been resolved: PCI: keystone: Fix if-statement expression in ks_pcie_quirk() This code accidentally uses && where || was intended. It potentially results in a NULL dereference. Thus, fix the if-statement expression to use the correct condition. [kwilczynski: commit log]

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00219 12th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.4.285, 5.10.227, 5.15.168 +5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux5.4.284 to before 5.4.285; 5.10.226 to before 5.10.227; 5.15.167 to before 5.15.168; 6.1.110 to before 6.1.113; 6.6.51 to before 6.6.54; 6.10.10 to before 6.10.135.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.54, 6.10.13Patch availableCNA
LinuxLinux6.11 and later5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.54, 6.10.13, 6.11.2, 6.12Patch availableCNA
  • Linux VendorLinux Affected 5.4.284 to before 5.4.285; 5.10.226 to before 5.10.227; 5.15.167 to before 5.15.168; 6.1.110 to before 6.1.113; 6.6.51 to before 6.6.54; 6.10.10 to before 6.10.13 Fixed in 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.54, 6.10.13 Patch available CNA
  • Linux VendorLinux Affected 6.11 and later Fixed in 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.54, 6.10.13, 6.11.2, 6.12 Patch available CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*5.4.284 to before 5.5; 6.1.110 to before 6.1.113; 6.6.51 to before 6.6.54; 6.10.10 to before 6.10.13; 6.11 to before 6.11.2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:5.10.226:*:*:*:*:*:*:*5.10.226VulnerableLinux
cpe:2.3:o:linux:linux_kernel:5.15.167:*:*:*:*:*:*:*5.15.167VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.4.284 to before 5.5; 6.1.110 to before 6.1.113; 6.6.51 to before 6.6.54; 6.10.10 to before 6.10.13; 6.11 to before 6.11.2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:5.10.226:*:*:*:*:*:*:* Versions 5.10.226 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:5.15.167:*:*:*:*:*:*:* Versions 5.15.167 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.54, 6.10.13
  • Fix · CNA Linux (Linux) Fixed in 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.54, 6.10.13, 6.11.2, 6.12

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 4 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-47756
  2. 2026-10-03 Alias added: GHSA-fw6v-6fqv-jxv4

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources