GLPI has a stored XSS via document upload
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
GLPI is a free Asset and IT management software package. An technician can upload a SVG containing a malicious script. The script will then be executed when any user will try to see the document contents. Upgrade to 10.0.17.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00455 39th percentileScored 2026-11-07
Fix Fixed glpi (glpi-project): 10.0.17
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| glpi-project | glpi | 9.2.0 to before 10.0.17 | 10.0.17 | Patch available | CNA |
- glpi Vendorglpi-project Affected 9.2.0 to before 10.0.17 Fixed in 10.0.17 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* | 9.2.0 to before 10.0.17 | Vulnerable | glpi-project |
- cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* Versions 9.2.0 to before 10.0.17 Vulnerable ·glpi-project
Remediation
- Fix · CNA glpi (glpi-project) Fixed in 10.0.17
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47759
References
More glpi-project Glpi vulnerabilities
- TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
- TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
- TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
- TI-2023-18602 GLPI vulnerable to SQL injection through Computer Virtual Machine information CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences