Action Controller has possible ReDoS vulnerability in HTTP Token authentication
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-1333.
Summary
Action Pack is a framework for handling and responding to web requests. Starting in version 4.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in Action Controller's HTTP Token authentication. For applications using HTTP Token authentication via `authenticate_or_request_with_http_token` or similar, a carefully crafted header may cause header parsing to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may choose to use Ruby 3.2 as a workaround.Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Rails | rails | 4.0.0 to before 6.1.7.9; 7.0.0 to before 7.0.8.5; 7.1.0 to before 7.1.4.1; 7.2.0 to before 7.2.1.1 | 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1 | Patch available | CNA |
| — | actionpack (RubyGems) | 4.0.0 to before 6.1.7.9 | 6.1.7.9 | Patch available | GHSA-vfg9-r3fq-jvx4 |
| — | actionpack (RubyGems) | 7.0.0 to before 7.0.8.5 | 7.0.8.5 | Patch available | GHSA-vfg9-r3fq-jvx4 |
| — | actionpack (RubyGems) | 7.1.0 to before 7.1.4.1 | 7.1.4.1 | Patch available | GHSA-vfg9-r3fq-jvx4 |
| — | actionpack (RubyGems) | 7.2.0 to before 7.2.1.1 | 7.2.1.1 | Patch available | GHSA-vfg9-r3fq-jvx4 |
- rails VendorRails Affected 4.0.0 to before 6.1.7.9; 7.0.0 to before 7.0.8.5; 7.1.0 to before 7.1.4.1; 7.2.0 to before 7.2.1.1 Fixed in 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1 Patch available CNA
- actionpack (RubyGems) Vendor— Affected 4.0.0 to before 6.1.7.9 Fixed in 6.1.7.9 Patch available GHSA-vfg9-r3fq-jvx4
- actionpack (RubyGems) Vendor— Affected 7.0.0 to before 7.0.8.5 Fixed in 7.0.8.5 Patch available GHSA-vfg9-r3fq-jvx4
- actionpack (RubyGems) Vendor— Affected 7.1.0 to before 7.1.4.1 Fixed in 7.1.4.1 Patch available GHSA-vfg9-r3fq-jvx4
- actionpack (RubyGems) Vendor— Affected 7.2.0 to before 7.2.1.1 Fixed in 7.2.1.1 Patch available GHSA-vfg9-r3fq-jvx4
Remediation
- Fix · CNA rails (rails) Fixed in 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1
- Fix · GHSA-vfg9-r3fq-jvx4 actionpack (RubyGems) Fixed in 6.1.7.9 Advisory →
- Fix · GHSA-vfg9-r3fq-jvx4 actionpack (RubyGems) Fixed in 7.0.8.5 Advisory →
- Fix · GHSA-vfg9-r3fq-jvx4 actionpack (RubyGems) Fixed in 7.1.4.1 Advisory →
- Fix · GHSA-vfg9-r3fq-jvx4 actionpack (RubyGems) Fixed in 7.2.1.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47887
- 2026-10-03 Alias added: GHSA-vfg9-r3fq-jvx4
References
Other 7
- https://github.com/rails/rails/security/advisories/GHSA-vfg9-r3fq-jvx4
- https://github.com/rails/rails/commit/56b2fc3302836405b496e196a8d5fc0195e55049
- https://github.com/rails/rails/commit/7c1398854d51f9bb193fb79f226647351133d08a
- https://github.com/rails/rails/commit/8e057db25bff1dc7a98e9ae72e0083825b9ac545
- https://github.com/rails/rails/commit/f4dc83d8926509d0958ec21fcdbc2e7df3d32ce2
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2024-47887.yml
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2026-47043 Action Pack: Possible arbitrary file read and remote code execution in Active Storage variant processing CVSS 4.0CRITICAL 9.5
- TI-2025-18040 Command injection in Rails activestorage CVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-47887 · CVE Program
- CVE-2024-47887 · NVD
- FIRST EPSS
- GHSA-vfg9-r3fq-jvx4 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-47887 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences