Action Mailer has possible ReDoS vulnerability in block_format
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-1333.
Summary
Action Mailer is a framework for designing email service layers. Starting in version 3.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the block_format helper in Action Mailer. Carefully crafted text can cause the block_format helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling the `block_format` helper or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 requires Ruby 3.2 or greater so is unaffected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Rails | rails | 3.0.0 to before 6.1.7.9; 7.0.0 to before 7.0.8.5; 7.1.0 to before 7.1.4.1; 7.2.0 to before 7.2.1.1 | 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1 | Patch available | CNA |
| — | actionmailer (RubyGems) | 3.0.0 to before 6.1.7.9 | 6.1.7.9 | Patch available | GHSA-h47h-mwp9-c6q6 |
| — | actionmailer (RubyGems) | 7.0.0 to before 7.0.8.5 | 7.0.8.5 | Patch available | GHSA-h47h-mwp9-c6q6 |
| — | actionmailer (RubyGems) | 7.1.0 to before 7.1.4.1 | 7.1.4.1 | Patch available | GHSA-h47h-mwp9-c6q6 |
| — | actionmailer (RubyGems) | 7.2.0 to before 7.2.1.1 | 7.2.1.1 | Patch available | GHSA-h47h-mwp9-c6q6 |
- rails VendorRails Affected 3.0.0 to before 6.1.7.9; 7.0.0 to before 7.0.8.5; 7.1.0 to before 7.1.4.1; 7.2.0 to before 7.2.1.1 Fixed in 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1 Patch available CNA
- actionmailer (RubyGems) Vendor— Affected 3.0.0 to before 6.1.7.9 Fixed in 6.1.7.9 Patch available GHSA-h47h-mwp9-c6q6
- actionmailer (RubyGems) Vendor— Affected 7.0.0 to before 7.0.8.5 Fixed in 7.0.8.5 Patch available GHSA-h47h-mwp9-c6q6
- actionmailer (RubyGems) Vendor— Affected 7.1.0 to before 7.1.4.1 Fixed in 7.1.4.1 Patch available GHSA-h47h-mwp9-c6q6
- actionmailer (RubyGems) Vendor— Affected 7.2.0 to before 7.2.1.1 Fixed in 7.2.1.1 Patch available GHSA-h47h-mwp9-c6q6
Remediation
- Fix · CNA rails (rails) Fixed in 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1
- Fix · GHSA-h47h-mwp9-c6q6 actionmailer (RubyGems) Fixed in 6.1.7.9 Advisory →
- Fix · GHSA-h47h-mwp9-c6q6 actionmailer (RubyGems) Fixed in 7.0.8.5 Advisory →
- Fix · GHSA-h47h-mwp9-c6q6 actionmailer (RubyGems) Fixed in 7.1.4.1 Advisory →
- Fix · GHSA-h47h-mwp9-c6q6 actionmailer (RubyGems) Fixed in 7.2.1.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47889
- 2026-10-03 Alias added: GHSA-h47h-mwp9-c6q6
References
Other 7
- https://github.com/rails/rails/security/advisories/GHSA-h47h-mwp9-c6q6
- https://github.com/rails/rails/commit/0e5694f4d32544532d2301a9b4084eacb6986e94
- https://github.com/rails/rails/commit/3612e3eb3fbafed4f85e1c6ea4c7b6addbb0fdd3
- https://github.com/rails/rails/commit/985f1923fa62806ff676e41de67c3b4552131ab9
- https://github.com/rails/rails/commit/be898cc996986decfe238341d96b2a6573b8fd2e
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionmailer/CVE-2024-47889.yml
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2026-47043 Action Pack: Possible arbitrary file read and remote code execution in Active Storage variant processing CVSS 4.0CRITICAL 9.5
- TI-2025-18040 Command injection in Rails activestorage CVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-47889 · CVE Program
- CVE-2024-47889 · NVD
- FIRST EPSS
- GHSA-h47h-mwp9-c6q6 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-47889 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences