Vendure asset server plugin has local file read vulnerability with AssetServerPlugin & LocalAssetStorageStrategy
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Vendure is an open-source headless commerce platform. Prior to versions 3.0.5 and 2.3.3, a vulnerability in Vendure's asset server plugin allows an attacker to craft a request which is able to traverse the server file system and retrieve the contents of arbitrary files, including sensitive data such as configuration files, environment variables, and other critical data stored on the server. In the same code path is an additional vector for crashing the server via a malformed URI. Patches are available in versions 3.0.5 and 2.3.3. Some workarounds are also available. One may use object storage rather than the local file system, e.g. MinIO or S3, or define middleware which detects and blocks requests with urls containing `/../`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vendure-ecommerce | vendure | before 2.3.3; 3.0.0 to before 3.0.5 | 2.3.3, 3.0.5 | Patch available | CNA |
| — | @vendure/asset-server-plugin (npm) | before 2.3.3 | 2.3.3 | Patch available | GHSA-r9mq-3c9r-fmjq |
| — | @vendure/asset-server-plugin (npm) | 3.0.0 to before 3.0.5 | 3.0.5 | Patch available | GHSA-r9mq-3c9r-fmjq |
- vendure Vendorvendure-ecommerce Affected before 2.3.3; 3.0.0 to before 3.0.5 Fixed in 2.3.3, 3.0.5 Patch available CNA
- @vendure/asset-server-plugin (npm) Vendor— Affected before 2.3.3 Fixed in 2.3.3 Patch available GHSA-r9mq-3c9r-fmjq
- @vendure/asset-server-plugin (npm) Vendor— Affected 3.0.0 to before 3.0.5 Fixed in 3.0.5 Patch available GHSA-r9mq-3c9r-fmjq
Remediation
- Fix · CNA vendure (vendure-ecommerce) Fixed in 2.3.3, 3.0.5
- Fix · GHSA-r9mq-3c9r-fmjq @vendure/asset-server-plugin (npm) Fixed in 2.3.3 Advisory →
- Fix · GHSA-r9mq-3c9r-fmjq @vendure/asset-server-plugin (npm) Fixed in 3.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-48914
- 2026-10-03 Alias added: GHSA-r9mq-3c9r-fmjq
References
Other 5
- https://github.com/vendure-ecommerce/vendure/security/advisories/GHSA-r9mq-3c9r-fmjq
- https://github.com/vendure-ecommerce/vendure/commit/e2ee0c43159b3d13b51b78654481094fdd4850c5
- https://github.com/vendure-ecommerce/vendure/commit/e4b58af6822d38a9c92a1d8573e19288b8edaa1c
- https://github.com/vendure-ecommerce/vendure/blob/801980e8f599c28c5059657a9d85dd03e3827992/packages/asset-server-plugin/src/plugin.ts#L352-L358
- https://github.com/vendure-ecommerce/vendure
Sources
- CVE-2024-48914 · CVE Program
- CVE-2024-48914 · NVD
- FIRST EPSS
- GHSA-r9mq-3c9r-fmjq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences