Read the docs
TI-2024-32953 Aliases CVE-2024-49365GHSA-5vhg-9xg4-cv9m

tiny-secp256k1 allows for verify() bypass when running in bundled environment

Priority HIGH 76CWE-347Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-347.

Summary

tiny-secp256k1 is a tiny secp256k1 native/JS wrapper. Prior to version 1.1.7, a malicious JSON-stringifyable message can be made passing on verify(), when global Buffer is the buffer package. This affects only environments where require('buffer') is the NPM buffer package. Buffer.isBuffer check can be bypassed, resulting in strange objects being accepted as a message, and those messages could trick verify() into returning false-positive true values. This issue has been patched in version 1.1.7.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00247 16th percentileScored 2026-11-07
Fix Fixed tiny-secp256k1 (bitcoinjs): 1.1.7tiny-secp256k1 (npm): 1.1.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
bitcoinjstiny-secp256k1before 1.1.71.1.7Patch availableCNA
—tiny-secp256k1 (npm)before 1.1.71.1.7Patch availableGHSA-5vhg-9xg4-cv9m
  • tiny-secp256k1 Vendorbitcoinjs Affected before 1.1.7 Fixed in 1.1.7 Patch available CNA
  • tiny-secp256k1 (npm) Vendor— Affected before 1.1.7 Fixed in 1.1.7 Patch available GHSA-5vhg-9xg4-cv9m

Remediation

  • Fix · CNA tiny-secp256k1 (bitcoinjs) Fixed in 1.1.7
  • Fix · GHSA-5vhg-9xg4-cv9m tiny-secp256k1 (npm) Fixed in 1.1.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-49365
  2. 2026-10-03 Alias added: GHSA-5vhg-9xg4-cv9m

References

  • TI-2024-32952 Insufficiently protected credentials in bitcoinjs tiny-secp256k1 CVSS 4.0HIGH 8.1
  • TI-2026-85137 bitcoinjs-lib block root check accepts duplicated transaction lists CVSS 4.0CRITICAL 9.3

Sources