net/smc: check iparea_offset and ipv6_prefixes_cnt when receiving proposal msg
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: net/smc: check iparea_offset and ipv6_prefixes_cnt when receiving proposal msg When receiving proposal msg in server, the field iparea_offset and the field ipv6_prefixes_cnt in proposal msg are from the remote client and can not be fully trusted. Especially the field iparea_offset, once exceed the max value, there has the chance to access wrong address, and crash may happen. This patch checks iparea_offset and ipv6_prefixes_cnt before using them.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.16 and later | 5.10.233, 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13 | Patch available | CNA |
- Linux VendorLinux Affected 4.16 and later Fixed in 5.10.233, 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.16 to before 5.10.233; 5.11 to before 5.15.176; 5.16 to before 6.1.122; 6.2 to before 6.6.68; 6.7 to before 6.12.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc1:*:*:*:*:*:* | 6.13 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc2:*:*:*:*:*:* | 6.13 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc3:*:*:*:*:*:* | 6.13 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.16 to before 5.10.233; 5.11 to before 5.15.176; 5.16 to before 6.1.122; 6.2 to before 6.6.68; 6.7 to before 6.12.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc1:*:*:*:*:*:* Versions 6.13 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc2:*:*:*:*:*:* Versions 6.13 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc3:*:*:*:*:*:* Versions 6.13 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.233, 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2024-49571
- 2026-10-03 Alias added: GHSA-xjw7-4j5c-v8ww
References
Patch 6
- https://git.kernel.org/stable/c/846bada23bfcdeb83621b045ed85dc06c7833ff0
- https://git.kernel.org/stable/c/f10635268a0a49ee902a3b63b5dbb76f4fed498e
- https://git.kernel.org/stable/c/62056d1592e63d85e82357ee2ae6a6a294f440b0
- https://git.kernel.org/stable/c/91a7c27c1444ed4677b83fd5308d2cf03f5f0851
- https://git.kernel.org/stable/c/47ce46349672a7e0c361bfe39ed0b22e824ef4fb
- https://git.kernel.org/stable/c/a29e220d3c8edbf0e1beb0f028878a4a85966556
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-49571 · CVE Program
- CVE-2024-49571 · NVD
- FIRST EPSS
- GHSA-xjw7-4j5c-v8ww · GitHub Advisory Database · CC BY 4.0
- CVE-2024-49571 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences