OS command injection in Dell Unity
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
Dell Unity, version(s) 5.4 and prior, contain(s) an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to Command execution.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Unity (Dell) Fixed in 5.5.0.0.5.259
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Dell Unity — dell.com/support/kbdoc/en-us/000300090/dsa-2025-116-securit…
14 records Highest priority Priority MEDIUM 5 MEDIUM, 9 LOW
Other records, highest priority first
- TI-2025-16296 OS command injection in Dell UnityPriority MEDIUM 53
- TI-2025-18126 OS command injection in Dell UnityPriority MEDIUM 50
- TI-2025-18125 OS command injection in Dell UnityPriority MEDIUM 43
Timeline
- 2026-10-02 Threatist record created from CVE-2024-49601
- 2026-10-03 Alias added: GHSA-892f-rc2x-gfvf
References
More Dell Unity Operating Environment vulnerabilities
- TI-2025-24909 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-16296 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18126 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.1
- TI-2022-11638 Missing brute-force protection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18125 OS command injection in Dell Unity CVSS 3.1HIGH 7.3
- TI-2025-18124 Open redirect in Dell Unity CVSS 3.1HIGH 8.8
Sources
- CVE-2024-49601 · CVE Program
- CVE-2024-49601 · NVD
- FIRST EPSS
- GHSA-892f-rc2x-gfvf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences