aoe: fix the potential use-after-free problem in more places
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: aoe: fix the potential use-after-free problem in more places For fixing CVE-2023-6270, f98364e92662 ("aoe: fix the potential use-after-free problem in aoecmd_cfg_pkts") makes tx() calling dev_put() instead of doing in aoecmd_cfg_pkts(). It avoids that the tx() runs into use-after-free. Then Nicolai Stange found more places in aoe have potential use-after-free problem with tx(). e.g. revalidate(), aoecmd_ata_rw(), resend(), probe() and aoecmd_cfg_rsp(). Those functions also use aoenet_xmit() to push packet to tx queue. So they should also use dev_hold() to increase the refcnt of skb->dev. On the other hand, moving dev_put() to tx() causes that the refcnt of skb->dev be reduced to a negative value, because corresponding dev_hold() are not called in revalidate(), aoecmd_ata_rw(), resend(), probe(), and aoecmd_cfg_rsp(). This patch fixed this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19.311 to before 4.19.323; 5.4.273 to before 5.4.285; 5.10.214 to before 5.10.227; 5.15.153 to before 5.15.168; 6.1.83 to before 6.1.113; 6.6.23 to before 6.6.55; 6.7.11 to before 6.8; 6.8.2 to before 6.9 | 4.19.323, 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.55, 6.8, 6.9 | Patch available | CNA |
| Linux | Linux | 6.9 and later | 4.19.323, 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.55, 6.10.14, 6.11.3, 6.12 | Patch available | CNA |
- Linux VendorLinux Affected 4.19.311 to before 4.19.323; 5.4.273 to before 5.4.285; 5.10.214 to before 5.10.227; 5.15.153 to before 5.15.168; 6.1.83 to before 6.1.113; 6.6.23 to before 6.6.55; 6.7.11 to before 6.8; 6.8.2 to before 6.9 Fixed in 4.19.323, 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.55, 6.8, 6.9 Patch available CNA
- Linux VendorLinux Affected 6.9 and later Fixed in 4.19.323, 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.55, 6.10.14, 6.11.3, 6.12 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.10.214 to before 5.10.227; 5.15.153 to before 5.15.168; 6.1.83 to before 6.1.113; 6.6.23 to before 6.6.55; 6.7.11 to before 6.8.2; 6.9 to before 6.10.14; 6.11 to before 6.11.3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:4.19.311:*:*:*:*:*:*:* | 4.19.311 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.4.273:*:*:*:*:*:*:* | 5.4.273 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.12:rc1:*:*:*:*:*:* | 6.12 rc1 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.10.214 to before 5.10.227; 5.15.153 to before 5.15.168; 6.1.83 to before 6.1.113; 6.6.23 to before 6.6.55; 6.7.11 to before 6.8.2; 6.9 to before 6.10.14; 6.11 to before 6.11.3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:4.19.311:*:*:*:*:*:*:* Versions 4.19.311 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.4.273:*:*:*:*:*:*:* Versions 5.4.273 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.12:rc1:*:*:*:*:*:* Versions 6.12 rc1 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.323, 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.55, 6.8, 6.9
- Fix · CNA Linux (Linux) Fixed in 4.19.323, 5.4.285, 5.10.227, 5.15.168, 6.1.113, 6.6.55, 6.10.14, 6.11.3, 6.12
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-49982
- 2026-10-03 Alias added: GHSA-g9fr-wfpx-28xj
References
Patch 7
- https://git.kernel.org/stable/c/f63461af2c1a86af4217910e47a5c46e3372e645
- https://git.kernel.org/stable/c/07b418d50ccbbca7e5d87a3a0d41d436cefebf79
- https://git.kernel.org/stable/c/bc2cbf7525ac288e07d465f5a1d8cb8fb9599254
- https://git.kernel.org/stable/c/acc5103a0a8c200a52af7d732c36a8477436a3d3
- https://git.kernel.org/stable/c/89d9a69ae0c667e4d9d028028e2dcc837bae626f
- https://git.kernel.org/stable/c/8253a60c89ec35c8f36fb2cc08cdf854c7a3eb58
- https://git.kernel.org/stable/c/6d6e54fc71ad1ab0a87047fd9c211e75d86084a3
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-49982 · CVE Program
- CVE-2024-49982 · NVD
- FIRST EPSS
- GHSA-g9fr-wfpx-28xj · GitHub Advisory Database · CC BY 4.0
- CVE-2024-49982 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences