scsi: wd33c93: Don't use stale scsi_pointer value
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: scsi: wd33c93: Don't use stale scsi_pointer value A regression was introduced with commit dbb2da557a6a ("scsi: wd33c93: Move the SCSI pointer to private command data") which results in an oops in wd33c93_intr(). That commit added the scsi_pointer variable and initialized it from hostdata->connected. However, during selection, hostdata->connected is not yet valid. Fix this by getting the current scsi_pointer from hostdata->selecting.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.18 and later | 6.1.113, 6.6.57, 6.11.4, 6.12 | Patch available | CNA |
- Linux VendorLinux Affected 5.18 and later Fixed in 6.1.113, 6.6.57, 6.11.4, 6.12 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.18 to before 6.1.113; 6.2 to before 6.6.57; 6.7 to before 6.11.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.12:rc1:*:*:*:*:*:* | 6.12 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.12:rc2:*:*:*:*:*:* | 6.12 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.18 to before 6.1.113; 6.2 to before 6.6.57; 6.7 to before 6.11.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.12:rc1:*:*:*:*:*:* Versions 6.12 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.12:rc2:*:*:*:*:*:* Versions 6.12 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.113, 6.6.57, 6.11.4, 6.12
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-50026
- 2026-10-03 Alias added: GHSA-hw89-rwr4-65g5
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-50026 · CVE Program
- CVE-2024-50026 · NVD
- FIRST EPSS
- GHSA-hw89-rwr4-65g5 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-50026 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences