net: fec: don't save PTP state if PTP is unsupported
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: net: fec: don't save PTP state if PTP is unsupported Some platforms (such as i.MX25 and i.MX27) do not support PTP, so on these platforms fec_ptp_init() is not called and the related members in fep are not initialized. However, fec_ptp_save_state() is called unconditionally, which causes the kernel to panic. Therefore, add a condition so that fec_ptp_save_state() is not called if PTP is not supported.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.10.14 to before 6.11 | 6.11 | Patch available | CNA |
| Linux | Linux | 6.6.55 to before 6.6.57; 6.11.3 to before 6.11.4 | 6.6.57, 6.11.4 | Patch available | CNA |
- Linux VendorLinux Affected 6.10.14 to before 6.11 Fixed in 6.11 Patch available CNA
- Linux VendorLinux Affected 6.6.55 to before 6.6.57; 6.11.3 to before 6.11.4 Fixed in 6.6.57, 6.11.4 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.6.55 to before 6.6.57; 6.7 to before 6.11.4; 6.10.4 to before 6.11 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.12:rc1:*:*:*:*:*:* | 6.12 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.12:rc2:*:*:*:*:*:* | 6.12 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.6.55 to before 6.6.57; 6.7 to before 6.11.4; 6.10.4 to before 6.11 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.12:rc1:*:*:*:*:*:* Versions 6.12 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.12:rc2:*:*:*:*:*:* Versions 6.12 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.11
- Fix · CNA Linux (Linux) Fixed in 6.6.57, 6.11.4
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-50097
- 2026-10-03 Alias added: GHSA-wggq-gr89-33vp
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-50097 · CVE Program
- CVE-2024-50097 · NVD
- FIRST EPSS
- GHSA-wggq-gr89-33vp · GitHub Advisory Database · CC BY 4.0
- CVE-2024-50097 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences